[Solved]Can't get wired network connection on OSMC


i installed OSMC on my raspberry to supersede the old raspbmc os.

Now i can’t get a network connection on OSMC. I tried static and dhcp setup.
The strange thing is, that sometimes (in the frontend) an ip address appears for 1/2 seconds, also the network led switches severeal times on/off. :frowning:

If i tried to activate the network adapter in osmc settings, the system tries to configure it, fails and set the status back to disabled.

With raspbmc the network connection works without any problems…

On hardware site im using the old raspberry model b and a full duplex fast ethernet connection (100 MBit/s, CAT5).

Does anyone has the same problem? Can anyone help ? … i don’t won’t to go back to raspbmc :frowning:


Are you using the default overclock speeds ?

Have you tried a different power adaptor ?

Hallo DBMandrake,

thank you for replying. :smiley:

I’m using the default overclock speeds, but I also tried to set lower speeds via custom settings. ( found some posts who says it’s a low power problem)

I’m still using the same power adapter.

If I flash another OS for example rasbian, network works without any problems, so I guess it’s not an hardware issue… Right?

so here a little update:

Finally it’s working :blush:

I flashed the RC1 and everything is fine.

Anyway I got network problems with RC3 and 2015-06_1 Release.

Hopes this helps anyone who’s exploring the same problem.

I don’t believe this is actually solved. Falling back to an early release candidate instead of using the the official release does not solve the problem.
I have a similar issue with the official release. Says no internet. Works fine on RaspBMC that was installed on an identical identical Pi B, and another on a much older version of Raspbmc which is on another similar network switch further downstream.
The Pi is connected to a Netgear GS305 switch, which is connected to a Sky broadband router.
OSMC shows an IP address, but this isn’t in the range I would be expecting (192.168.0.x), I’m not a network expert so I may not know what I’m doing though.

Where does it say no internet ? Under Networking in My OSMC, or under Settings, System information ?

What is the IP address it reports ? I’m assuming its 169.254.x.x - this is a self assigned IP address that a device will use if it is configured for DHCP but doesn’t get any DHCP response.

Have you tried 1) reducing your overclock 2) a different power adaptor, 3) a different ethernet cable ?

Ah OK, yes, 169.254.x.x
It says Internet: Not connected. Check network settings. in Settings>System info>Network
Also says Status: eth0 (No internet) under networking.
The power supply is a 1.5A one, the recommended one. I’ve got two other identical power supplies.
I’ve tried a different cable to a different port on the Network Switch. Same problem. I’ll try plugging it directly into the broadband router instead, will also try another power supply.
I haven’t overclocked the Pi, it’s set on normal in OSMC.

The power supply and network cable work fine on an identical Pi B running latest verson RaspBMC.

Hmm, wonder whether the Ethernet port on the Pi is broken. Might swap the SD and USB to the Pi that works fine and see what happens…

Well that was a total surprise! Swapped the SD card and USB to another Pi, and it’s instantly working.

Thanks for the help. Note to self, never assume the part that was working is not now broken.

I’ll pull apart the other Pi, maybe it’s the network port or something!?

I wonder if I’m experiencing something similar with my Pi2. Everything has been working fine for a while, but I reorganized my “media room” this weekend. When I went to turn the Pi on, I got the “frowny-face then reset” cycle.

After some troubleshooting, and replacing the power adapter (2.0A), I discovered that it would boot without problems if I unplugged the network cable. I can then plug the cable in, and everything is fine except that it doesn’t show the “Movie” or “TV” menu items since it didn’t find any at start-up.

I’ve tried replacing the network cable, I’ve tried plugging into two different ethernet switches. I’ll post more if I actually figure out the problem.

EDIT: My problems seem to have come from the last update. I moved back to 2015.08-1 and everything was okay. The same update has caused “freezing” problems on a different Pi that uses a MMC remote with a USB receiver. Rolling that one back fixed that problem as well.

A post was merged into an existing topic: January 2016.0.1-1 Update broke my Ethernet module

I’m still having this issue :frowning:

Check your network. Change your cable, try without your switch. It’s a local problem.