[Solved] Can't play full HD content

Hey there! First of all a big thank you to all members of this awesome project!

I am not sure if I am in the right area. So if I am in the wrong area just move my topic into the correct area.

I got issues playing full hd content with osmc (RC) on my raspberry pi2. Is there anything known? I just get a black screen if I start playback.

I licensed the codecs and vcgencmd tells the following:


I posted my log here: http://pastebin.com/BhV6Lw1N

I also stumbled over another hint googling around. That seems hardware acceleration in omxplayer is disabled.
Unfortunately I am quite a linux noob and this directory “/usr/lib/omxplayer/” does not exist.

Has anybody else this problem or a maybe solution?

 - could not setup tunnel src OMX.broadcom.audio_splitter port 262 dst 
OMX.broadcom.audio_render port 100 omx_err(0x8000100c)12:17:23 T:1254093856   ERROR: COMXAudio::Initialize - Error m_omx_tunnel_splitter_analog.Establish 0x8000100c12:17:23 T:1254093856   ERROR: COMXAudio::AddPackets - error PortSettingsChanged omx_err(0x00000000)````

How is your audio configured?

OMXPlayer is part of Kodi, where as that guide is for something slightly different. 

CC @popcornmix

Hi Sam! :smile:

I got the following setup:
Audio Output Device: HDMI and Analogue
Number of channels: 5.1
Output configuration: Optimized
Stereo upmix: enabled
Maintain original volume on downmix: enabled
Boost Centre: 30dB

Enable passthrough: enabled
AC3 capable receiver: enabled
E-AC3 capable receiver: disabled
DTS capable receiver: enabled

I think I changed the Audio ouput device because of squeezelite. But I am not sure anymore why. I think Kodi was not giving any audio output after I listened music via squeezelite.

Maybe it is relevant. Squeezelite is using hdmi as well.

OMXPlayer is part of Kodi, where as that guide is for something slightly different.

I suspected something like that. :wink:


I was able to solve the issue myself. Thanks for the hint with the audio setup, Sam!

For using squeezelite I had to install the Alsa package.
I had to select Alsa as Audio Output Device and to disable passthrough.