[SOLVED]choppy netflix on rpi3


Fisrtly, hello to everybody on this forum (my first post here…).
Well, I’ve managed to install netflix as an kodi extension video on my raspberry pi 3 media center coupled with a FullHD TV). Not an easy task but people out there worked hard for that so kudos to them, especially the guys here that provided the correct explanations and links.
I can fill in and navigate netflix menus easily but I’ve very frustrating feelings:

  • From several profiles, the majority of movies and series are jerky, slow and often buffering. Some videos neverthless are smooth with no buffering.
  • From “kid” profile, everything is fine. no stuttering, smooth videos. But hey, i’m no more a kid !
  • with every profile, default audio/subtitles are german so i have to switch both in english each time and that is quite boring.

I’ve bought mpeg-2 and vc-1 license keys.
Kodi 19.0-RC4 is running on osmc 2018-10.1.
I’ve used ares wizard to optimize cache management, my internet bandwith is 10 MBytes/s and local wifi bandwith is 3 Mbytes/s between the router and the osmc rpi3.
I also can read locally nas-based fullhd videos perfectly with the osmc rpi3.
I’ve a 4K smartTV in my bedroom with netflix and it runs smoothly even with 4K streaming !

Any tips ?

Well you mention FullHD tv, are you trying to run netflix at 1080p? That won’t be possible with most of Netflix content, since Netflix is software decoded, the CPU on a PI3 isn’t fast enough to handle 1080p.

Under settings for netflix addon, go to account, inputstream settings. Chose max resultuition 720p on both max resolution

hey joachim,

i gave it a try by modifying inputstream options (max->720P) and it worked out.
Thanks. But it’s still a bit frustating to lower the resolution hence the video quality.
I’m thinking about switching to VERO 4K. is 1080P and 4K available and smooth on netflix with this device ?

Vero4k is better at it, BUT you still have dropped frames at the time of writing this. So even if it hurts to say, but are you looking for a 1080p Netflix experience in Kodi you need more raw CPU power, or an android device with the regular Netflix app.

OK thanks for the advice !

Hi Joakim, I am having a issue where my input stream setting is correct set to 720p on both max res. But it is not giving me that res. Not even as a option to select manually in Netflix. The highest option I get is 960x540. I used all your scripts to install. I also used your script to update my inputs team add on but it didn’t change anything. Any idea where I might start to figure out what is the cause? I’m also running a Pi 3