[Solved] Christmas update error

The Christmas update failed to install with “Error installing bash 4.3-11+b1, please report to the OSMC forum”. Running on Raspberry Pi Model B Rev 2 (cpuinfo revision 000e).
Checked using sudo apt-get dist-upgrade, returns:

Preconfiguring packages …
(Reading database … 25866 files and directories currently installed.)
Preparing to unpack …/bash_4.3-11+b1_armhf.deb …
dpkg: error processing archive /var/cache/apt/archives/bash_4.3-11+b1_armhf.deb (–unpack):
subprocess new pre-installation script was killed by signal (Segmentation fault)
update-alternatives: error: alternative path /usr/share/man/man7/bash-builtins.7.gz doesn’t exist
Errors were encountered while processing:
Let me know what logs/tests you may need.

grab-logs -A please.

Hi, logs uploaded at:
Note hostname and ip addresses replaced with ***

Comment out deb http://ftp.uk.debian.org/debian jessie main and try again.

Yep, that fixed it. I don’t remember adding a repo but I guess I was looking for a non-standard package at some point.
Thanks and have a great new year.