Solved: Dependency failed for Remote File System

Hi together,

I know that there are a lot of discussions out there and I am looking now for a very long time for a solution but non of the solutions worked so far for me. Here it is:

I run OSMC in the latest version on a Rasp 3B. Connecting to my shares directly via KODI does not work properly (not all files are detected) thus I added the shares in the fstab as follows:

//192.168.x.yyy/music /media/Musik cifs auto 0 0

This leads to the fact that OSMC is asking to enter a password during boot despite not password is set at all (public share).
Pressing works and after that the share is properly connected. Well, now I do not want to press a lot of returns during boot…

  • Tried to work with “guest” instead of auto;
  • tried to add added very different ways of password setting (e.g. credentials=/home/osmc/.smbcredentials,uid=osmc,gid=osmc,_netdev,x-systemd.automount 0 0) with or without a password in the smbcredentials

and so on and forth… Nothing worked, at the end I ended up with

“[FAILED] Failed to mount /…/… See systemctl status ... for details [DEPEND] Dependency failed for remote file systems.”

If I access than the system via SSH and start “mount -a”, all shares are conncected.

What can I do to have the shares mounted automatically?

Thanks, Tabaluga

Hi there,

after a lot of trials I finally found the solution for me:

//192.168.x.yyy/music /media/Musik cifs guest,noauto,x-systemd.automount 0 0”

So it was the combination of the “guest” together with “noauto,x-systemd.automount” that paid of… as both individual options did not work…

Thanks, Tabaluga