SOLVED: Disk full, bootloop, sad face :(

Hi guys,

Finally got chance to update 4K+ tonight. The update went fine, I installed a new skin and was downloading some dependencies and the next time I rebooted I saw an error message stating that I only had 2MB available. Kodi seemed to boot fine, and I was accessing the home directory via SMB to delete files and free up space, but quite quickly I was no longer able to access the folders from SMB and the mount was showing 0MB free.

I foolishly rebooted the 4K+ and this time the error message showed 0MB free, then sad face boot loop.

I was able to still login via SSH and remove files to free around 500MB (most of the files clogging my box are thumbnails from Emby, which I’ll need to follow up on separately) but the box still won’t boot up and all I get is sad face, flickering screen, sad face, repeat. I can still login via SSH though.

Logs here:

Hope it’s a reasonably simple fix or I’m going to have more sad faces to deal with in the morning when the wife and kids get up. Thanks in advance, guys!

I don’t recall if ncdu is installed by default, but try this from SSH:

ncdu ~osmc

that may help you figure out where the space is being used. If ncdu is not installed, try this instead:

   du -hs ~osmc | paste-log
   du -hs ~osmc/* | paste-log

and share the URLs.

Thanks @bmillham. I already tried that, which confirms that the biggest clog of data is in the user data folder, around 10gb of emby thumbnails. As I said, I’ve deleted some temp folders and stuff I’d backed up previously, and I think there was around 500MB free after doing that, but the sad face persists.

Unless I’m missing something? Will share the output requested tomorrow.

Will have to follow up again in the morning, night feeds beckon!

You should try using @milhouse’s pruning option.

10G is a lot of Thumbnails!

I’m not familiar with Emby, but does it have a way to configure where the thumbnails are saved? If it does try moving them to either one of your NFS mounted drives, or consider using a USB stick connected to the Vero to store them.

If Emby does not allow you to move them, you may still be able to put them on a USB stick, and then create a link from where Emby wants them to point to where they really are on the USB stick.

Thanks for the suggestion, @ActionA. I used to use many moons ago, but haven’t needed to for years. Doing some reading this morning and it seems that Emby’s Kodi app has it’s own in-built feature for caching artwork, which is based on texturecache (whether I’ve enabled it from the app is a bit more difficult to tell at the moment!).

Looking closer at the folders/files on the 4K+, it seems all the thumbs/artwork in the Emby folder is fanart. I’ve compared folder structure and filesize to my previous 4K (which hasn’t been used since I got the 4K+) and the same folder/files doesn’t exist. I don’t remember changing anything in the settings, but it would seem to suggest that I’ve selected to download many fanart options since upgrading to the 4K+.

I’m still seeing sadface boot loop, but I can now connect via SMB, so that folder is currently copying across to a USB stick so that I can free-up more space, but I don’t think that’s the issue now (as I said earlier, I’d already freed up close to 500MB).

Is it possible to see from the logs I shared what is causing the sad face on boot, whether it can be repaired or if I’m looking at a fresh reinstall?

Well it says
2019-06-06 00:04:36.134 T:4064952320 ERROR: CProfileManager: error loading special://masterprofile/profiles.xml, Line 0 Failed to open file

So maybe the full disk has give issues when the profile was written.
You might be able to rescue it by deletiing (or checking) the profile fiel.

1 Like

Deleting the profiles.xml file automatically corrected the bootloop error, thank you. Now to do something about all that fanart!

Thanks for your help!