[SOLVED] Disk not mounted by udisks-glue

Hi guys:

In the past days the external hdd stopped being mounted by udisks-glue.
In fact, it started to report that the partitions “did not match any rules”.

I had that 1 year ago, but it was a corruption at ntfs fs level, easily solved with a ntfsfix.

I had a small change at the configuration: using now an amazon powered usb hub in order to power the external disk and a wintv solohd DVB-c tuner.

The disk and partition are detected by udisk-glue. blkid lists also the correct labels and fs.

If I manually force the mounting of the partitions, it works ok.

The disk I’m using has a partition labelled as “hdd” and another labelled as “backups”.
Both are NTFS.

The log of udisks-glue is here:

Meanwhile, I’ve created a small set of commands in etc/rc.local, that waits some 30 seconds, and forces the partition mounting if not yet mounted.
(see bellow)
It solves the issue, but it is not the ideal solution.
Does anyone can help in detecting what is happening with udisks-glue ???

# rc.local
# This script is executed at the end of each multiuser runlevel
# Make sure that the script will return "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.

sleep 30

echo "Searching for unmounted external disks"
        if [ "$(mount | grep -o $DEVICE)" != "" ]; then
                echo "$DEVICE is mounted."
                echo "$DEVICE is not mounted. Fixing file system and mounting in /media/$LABEL"
                ntfsfix $DEVICE
                mkdir -p /media/$LABEL
                mount $DEVICE /media/$LABEL
# External disks are always connected as /dev/sd*
done <<< $(blkid | grep "/dev/sd")

echo "Setting sda standby timeout"
/sbin/hdparm -S 120 /dev/sda

exit 0

If you revert your ‘small change’ does the problem clear up? If it does, then make your changes step by step. Add the hub, see if there is a problem. Then add the tuner.

Without the Hub, there is not enough power for the RPi, the HDD and the tuner.
But connecting only the disk directly to the Pi, works fine.

The difference when connecting trough a usb hub, is the naming of the disk, that is reported as connected.
udisks-glue reports as 8.1 and 8.2 - could this be the issue ?

Is there anybody else using and external disk connected trough a usb-hub ? and with a dvb tuner ?

What hub did you use before?

What amazon hub is it?

I was not using any hub, and the disk failed to start or the tuner failed to start.
There was a very random chance of both working together (hdd seagate 2.5 inches, usb 3.0 2tb + hauppauge win tv dvb-c tuner).

So I’ve bought this hub from Amazon Basics: 7 port usb 2.0 powered hub.
It comes with a nice 5V 4A PSU, that is more than enough to power everything and still has margin for an additional hdd :slight_smile:

But allow me to formulate what I believe is the question:
Why does iDisks-glue refuses to mount the disk partitions if a normal mount works flawlessly ???

not sure whether /etc/udisks-glue.conf is the problem here with this 2 partitions hdd, perhaps one of the other mods/users has an idea

Perhaps, verify low hanging fruit at first: In case I found the right one on Amazon, your hub has two types of usb ports. The side with the 2 ports has 1200 mA ports, the other only “normal” 500 mA ones. I would try the ports with most power at first for the hdd.

1 Like

What happens if you try the disk and hub without the tuner?

If things still fail without the tuner, then the hub is at fault. I’ve used several hubs and have never seen a drive fail to mount. And since your workaround adds a sleep it seems like the hub is preventing the drive from spinning up. I’d try a different hub.

Thank’s man. That was the key for solving the problem !
Effectively, The hub seems to slows down the spin up.
So … Why not adding a small delay before calling udisk-glue ?

I’ve just edited udisks-glue.service.
Adding a “delay 5” before calling udisk-glue seemed enough to solve the issue !

I leave this suggestion, for dev’s if they are interested in open a little bit the comptibility of udisks-glue :wink:

Thank’s for your thoughts - they’ve helped me A LOT !!!

[of course, that editing the service file may not be the right approach. The clean choice would be to edit /etc/udisks-glue.conf, but I did not find a “pre_insertion_command”]

Changing the udisk-glue probably isn’t the best solution as it may be overwritten during an update.

And adding a generic delay isn’t a good solution either, as you are the first person to report something like this.

I’d really suggest that you replace the hub with a better one. It should not be delaying the spin-up speed of the drive.

1 Like

It’s a power issue.

1 Like

I thought of that. That’s why I’ve bought This hub with a 4A psu, Which keeps giving 5V with all devices connected.
Anyway, I will investigate further.

Do you suggest using a Ycable to give more current to the disk ?


I don’t know anything about the design of the hub you refer to advise to be completely honest.


1 Like

You should listen to @JimKnopf. Historically, with 7 port hubs, all ports may not behave the same with regards to power output.

1 Like

Volts (V) and Amps (A) are not the same thing. And how do you know that the supply is giving a steady 4A/5V?

If you need a Y cable, then then you need a proper hub! I have a hub with 4 drives connected and don’t need any Y cables.

Of course not ! (Electronics Engineer, here :sunglasses:)

I believe this is not the place to a basic electrics lesson :wink: , but I’ve confirmed with 2 approaches that the 5V are being provided.
1st: Using one of those dongles that connects to the usb hub and displays instant Voltage provided (V or U, to the purists) and Current being drawn (A);
2nd: To be sure, I’ve disassembled the hub and connected a multimeter directly to the psu input - and so not being dependent of unappropriated thinner wires uncapable of allowing 4A to pass trough.

About the current, the proper test would be to ask for higher charge up to 4A: As charging 1 iPad plus 2 iPhones, and confirm the psu keeps giving 5V.

I’ve not went that far, but connected: 1.8A (for the rpi, peek), + 0.8A (hdd peek) + 0.5 (tuner). + 0.8 (2nd hdd for test connection only). = 3.9 A (peek): The psu kept the 5V .
With the official raspberry pi PSU it was not possible to connect the pi and 2 hdd, (at least not the ones I have here).

The hub has 5 x 500 mA ports and 2 x “high power ports” - for optimising the space inside the box where I have everything, I’ve connected the disk to a 500 mA port - I already know that the disk needs a peek of 800 mA, (but I thought it was just for extreme conditions and as a safe precaution -again, sorry for this bad english sentence. i try to explained the best I can) so I need to move it to a high power port, or connect it to 2 ports.


The hub is really interesting: Before using it with the rpi, I’ve connected it to a PC with 2 hdd’s and forced several GB of movies to copy from 1 to another so to test the capability of powering the 2 hdd working at the same time.

I don’t rule out the issue being form the hub, but it sure feels strange to me “mount” working. And why does udisks-glue says that there is no “rule” to mount the disk ?

Yesterday night (after booting the pi with a sleep 5 delay in udisks-glue to make sure the disk is mounted, I was downloading a file with transmission, and watching a tv transmission with timeshift activated (recording and playing at the same time to the hdd, and everything worked flawlessly.

Anyway thanks for all your suggestions. I will investigate a little bit further.

Of course that being the only one to report this issue, makes me wonder that the problem should be from my side (even if I’ve detected some issues in the past that were after all shared by more users, we only didn’t knew about them before).

I know that being able to provide support to a open software and “open hardware” architecture is a crazy thing. That’s wht I try to report only an issue when I’m not able to fix it my self
And even when I am, I try then to detail it in order to help other users that may have similar issues.

In the end:
Thank you all for making osmc so great !


Done !

And to close the subject with a Solution:
It was a power issue !

In summary:
Connecting the hdd to

  1. one single 500mA port - udisks-glue refuses to mount the partitions.
  2. a “high power” port , works ok.
  3. two 500mA ports (thus getting up to 1A) with a usb3 Y Cable, also working ok.
1 Like