[Solved] Display freeze after downloading TVShows Subtitles

Hi all,

FYI - I am testing my new Vero4k+ (with the kids), and we tend to watch BigBang Theory all together lately (OV + french subtitltes).
Only - on the Vero4k+, when downloading the subtitles (subscene subititles add-on), it writes down it downloads, then the screen freezes.
I enabled debuging and made the entire exercise, and saw that effectively even the overlayed info froze (screen-freeze).
I then tried to download the subtitles again with the Favorite movie of my youngest (M6), and here everything works fine ???

Really weird. anyone has an idea as to what can be wrong?
Here the log: https://paste.osmc.tv/neranujiza

Difference in setup from Vero 4k and Vero 4k+:
Vero 4K: lircd for Harmony
Vero 4K+: Bluetoth for Harmony hub connectivity

The rest is very similar. Using the NAS Mysql DB and NFS shares (no FSTAB mounting).
Both device connected through ethernet.

Note that upon arrival, I updated the vero4k+ from the command line with: sudo apt update && sudo apt dist-ugprade (automatic updates are disabled on my devices. I do that always manually).
I updated all my devices at the same time (Vero2 / Vero4K) and both work fine.

Note: I did not backup the configuration from the Vero4K and restored it on the vero4k+.
Configuration was done manually (as every time I do that).

Does it happen with a provider like OpenSubtitles?
Is this the only freeze you get? Are you able to SSH in to the device or is it a hard lockup.


That is the only freeze. OpenSubtitles does not freeze. Just getting an error message that I have no user/pwd :slight_smile:

I’ll probably restore the backups of the vero 4K I have here, and dump these on the vero 4k+ and see if I manage to get it to run that way (tonight).

Any other hints are welcome :slight_smile:

That’s weird. I’m guessing there’s a bug with that addon.

This is what I think too, or a configuration that is different and incompatible with the setup. Will check it out when I have played back the backup tonight. Will ket you know :slight_smile:

Seen very similar issues reported with Subtitles and SMB Networking as well over on AML LE 8.2.4.x after this sequence of @fritsch_xbmc patches were added:


If that causes issues, then shouldn’t other subtitle add-ons also experience problems?
We’ve had that patch in for a long time without reports of problems.


I think I found something - I replicated the configuration of the Vero 4K to the Vero 4K+ (Of course, I left out some files, like fstab and remote.xml, as thse have changed).
But look at this:

osmc@vero4k2:~/.kodi/userdata/addon_data/service.subtitles.subscene/temp/85487501-a6e7-4052-b386-3fc13ae25dd2$ ls -las
total 252
 4 drwxr-xr-x 2 osmc osmc   4096 Sep 19 19:30 .
 4 drwxr-xr-x 3 osmc osmc   4096 Sep 19 19:30 …
244 -rw-r–r-- 1 osmc osmc 248281 Sep 19 19:30 subscene.zip
 0 -rw-r–r-- 1 osmc osmc      0 Sep 19 19:30 The.Big.Bang.Theory.S05E22.DVDRip.Z1.MADE.FR.srt
osmc@vero4k2:~/.kodi/userdata/addon_data/service.subtitles.subscene/temp/85487501-a6e7-4052-b386-3fc13ae25dd2$ unzip subscene.zip  
Archive:  subscene.zip
replace The.Big.Bang.Theory.S05E22.DVDRip.Z1.MADE.FR.srt? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
 inflating: The.Big.Bang.Theory.S05E22.DVDRip.Z1.MADE.FR.srt
unzip: bad length
unzip: invalid zip magic FADD99F7

So - something is bad on their end. And it is for all episodes of Season 5 apparently.
I will figure out a different way to download Subtitiles for the girls :slight_smile: No worry.


Yes looks like the .zip packages are corrupt on their end.

Yes - if the python script is using the same progrm to unzip the file, it could be stuck in waiting for someone to say “Y” to extract the file anyway (even though the length is not Ok).