[Solved] DTS not working on spdif output (AC3 works just fine)


I use the vero connected with spdif to my AV receiver. Playback of 5.1 sound coded as AC3 works fine
Playback of DTS 5.1 does not work so far. My It seems my AV receiver gets a 2.0 signal
In the settings I chose stereo off and audio passthrough on.

On my pi I was able to get DTS via HDMI to a HDMI switch with spdif output just fine

Any thoughts on this

Hi Chris

Assuming you always want the sound out of SPDIF, can you check the in Settings -> System, you have set both your audio device and passthrough device to SPDIF.

I also recommend you change Settings level to ‘Expert’ (it’s in the corner on the left). You will then see more audio options. Make sure that ‘DTS passthrough’ is enabled.


I will check this as soon as I com home today.

Hi all,

to receive DTS on the spdif or HDMI output it is indeed necessary to activate the expert level to access the advanced audio potions. There you need to set the flag to enable DTS passthrough.

No it’s working perfectly