[SOLVED] Error in mounting a USB External Hard Disk

HI All,

newbie here.
Ok so when I connect my External Hard Disk (ntfs format) to my OSMC all i can see is this icon on right hand corner

i tired fdisk and i can’t see my hard disk over there as well.

Thanks

https://osmc.tv/help/wiki/pi-power

S

1 Like

Thanks @sam_nazarko

I need to get a new power supply for this. I shouldn’t have order it from ebay :frowning:

[quote=“sam_nazarko, post:2, topic:3977, full:true”]
https://osmc.tv/help/wiki/pi-power[/quote]

From pi-power page:

The OSMC Shop stocks and sells the Official Raspberry Pi power supply which is a great way to ensure your device runs with complete reliability.

Not that I see.

We will have to update it. It only sells with official kits for now, because the weight of the unit makes it hard to ship worldwide.

Thanks

BTW guys I manage to power it up :smile:
My portable hard disk cable have 2 USB ports, I connect the other one for my PC which gives enough power to detect and mount!.

Thanks for your help!

If you have a 5v 2A+ power supply for your Pi, you can try turning on max_usb_current in Pi Config. My external HDD won’t work without that turned on.

well In my power adapter it says 5V and 2A (not 2A+)
Is it ok if I turn max_usb_current on in Pi Config?

Yes. I just meant that your power supply should have a rated output of 2 Amps or better to use the option safely.

yep! It worked! :smiley: thanks @leetwanker

1 Like