[solved]External BR Drive, when entered shows file system not BR disk content

#1

I’ve got a stand alone BD drive connected via USB. It used to work on my RPi 2B and now after several months when i tried to use it again it gives me the option in files menu, but it provides me with file system view, not the content of the disk.
Is there a way to make it work?

The BD Drive has it’s own power supply and it used to work some time ago

0 Likes

#2

I assume from what you’ve said that the drive must get mounted when you insert a disk (so you can see the files view).
Instead of selecting the files entry and going in to explore it, select the entry for the disk and use the context menu (equivalent to right-click with a mouse, but has to be suitably interpreted for a remote) to bring up a menu which has, amongst other entries a play option - and select that.
There should also be, in the settings menu Player/DVD an option to play automatically.
HTH
Derek

0 Likes

#3

You were right, I got used to everything mounting auto
I used sudo mount -t udf /dev/sr0 /mnt/iso
But now any ideas how it should look in fstab?
I tried
/dev/sr0 /mnt/iso udf ro,noauto,uid=1000,gid=1000 0 0
but it doesn’t work

0 Likes

#4

For all to be happy and stress free
Rejoice
working fstab entry for bluray, of course to avoid problems create directory mkdir /mnt/iso
/dev/sr0 /mnt/iso udf,iso9660 user,auto,uid=1000,gid=1000,mode=0777,dmode=0777,nosuid,noexec,nofail 0 0

0 Likes

#5

Glad to hear you’ve resolved the problem
Derek

0 Likes