Solved: Failing To Install OSMC On USB Stick


I’m trying to install OSMC on my Pi2 Model B, and I want it to run from a USB stick (SanDisk nano-fit, 16GB).
I’ve tried it multiple times, but it keeps installing it on my SD card. How am I sure of this?

  1. It crashes if I pull out the SD card, even long after it’s done booting, which it shouldn’t as far as I understand.
  2. The USB stick has 8 KB of data on it and the SD card has 113MB on one partition and 220MB on another.

In the installer, I chose “on a USB stick”, and the chose the SD card when prompted to choose the device.

It seems to me like I did everything ok. Maybe someone more experienced can shed some light on possible mistakes I made?

Thanks in advance.

This just occurred to me while writing the post - maybe the SD card is formatted with 2 partitions and that’s a problem. I’ll try again and update.

This can not be a full install.
Did you boot from the SD card and let the installer run? Installation depending on you device can take 10 to 30 minutes

I didn’t touch it until OSMC was up. Maybe I mistyped the numbers, but the SD card is 1GB so it couldn’t be much more. I think the problem is with partitioning as I stated in my reply, and the system recognized the 2nd SD partition as an external device. I’m retrying it now and will update soon.

Well try the reformat but definitely the second partition would not be recognised as external USB stick.
Did you use the current installer from

Reformatting didn’t help.

I downloaded the installer from less than a week ago, so it’s supposed to be the current installer.

The numbers were wrong, I was quoting the available memory.
The memory used is 20MB on the 1st partition, and 533MB on the 2nd one.

Thanks for the replies fzinken :slight_smile:

Ok, Thanks for the info. Need to check with the team.

1 Like

If you select a USB installation in the OSMC installer, it doesn’t matter how the USB stick is formatted, as the installer will format it to be a single ext4 partition.

Before inserting the card in the Pi, check preseed.cfg and the contents and post them here. After installation, re-insert the SD card in to pc and post ‘install.log’ here.


1 Like

So I downloaded the Installer again (from the same place), used the same settings (for the 5th time), read the preseed file (which seemed ok), booted up my Pi - and it worked!

Pure magic :slight_smile:

Thanks everyone for the help!