[SOLVED] Files won't show up in OSMC

I’ve had a Raspberry Pi lying around for a while and decided to dive OSMC a try. All my movies live on a Synology NAS. The install was easy enough, so I connected via SSH to mount my movies. It looks like the /home/osmc directory ships with: Movies Music Pictures TV_Shows as folders, so I mapped to Movies. From my ssh terminal:

osmc@osmc:~$ cd /home/osmc/Movies
osmc@osmc:~/Movies$ dir

So, I know the drive is properly mounted, but I can’t figure out how to heck to get the OSMC OS to see these. It’s a mix of AVI, MKV, and M4A.

My method for adding my movies in OSMC’s menus has been videos ->files ->add videos

Then it asks me for a browse file path. Nothing I type in results in any files showing up. I’ve tried:

It’s got to be something simple, what am I missing? I’m thinking /home/osmc/Movies as that’s the only one that seems to register as a valid file path, but no files show up.

1 Like

As they’re all under Movies, then that is the final element in your path.
When adding the videos, you’ll only see the path, not the contained files - for those you’ll have to browse under VIdeos to see the individual movie.
Hope that is clear enough, as I cannot give a picture to illustrate at he moment

1 Like

Gotchya, I see what you’re saying. I guess I was expecting the next window to show al the movies as well.

Now, any idea how to delete the 10 directories I created trying to get it to work :wink:

1 Like

If you have the options set, you can do it from the file browser (but I think they are off on installation)

I messed with the file browser, but nothing jumped out at me.

In case anyone finds this thread in the future:

Turns out you can also do it by navigating through videos (the same way you would to find the directory you want to play from) highlight the directory and press “c”, it will ask you if you want to remove the directory.

OK - if you are happy with that, mark this thread [SOLVED]


hi @dandnsmith, I am facing the same issue. can you please explain more how to fix this?

Which issue (this is a 2year old thread)?
If it is marking the thread solved - only the owner (in general) can do that.
If something else, I suggest you search the forums, and if you cannot resolve your problem, post a new thread