[Solved] FTP login and write issues

I have a hard drive on another system mounted in OSMC via NFS. When I FTP into OSMC, should I be able to write to files in this location?

I’m logging in via WinSCP and all of the folders have RWX access and are owned by OSMC. Do I need to login with anything other than the username/password of OSMC?


Where did you set up the NFS mount? I’m guessing /etc/fstab? NFS will have its own uid and gid mapping, but the directory it is mounted in should be owned by osmc:osmc too.


I have the mount point set (through /et/fstab) as /mnt/harddisc and this directory is owned by OSMC. Is there an option in fstab to give write permissions?

I can write through ftp to other locations but nothing under /mnt/harddisc. The error in WinSCP is: “Could not create file.”


  • Unmount the mount temporarily
  • Run sudo chown osmc:osmc /mnt/harddisc

I’ve just tried that, no change…

Apologies all, I had the NFS export set up as read only on the Server side.

I had tried deleting the ro flag in the export but it actually needs to be rw.

Problem solved…as you were!