[SOLVED] GUI and video's background is washed out grey after April update

#1

Since I updated my Vero 4k+ to the April update, the GUI (Estuary) and the not-HDR videos are washed out. The result is that the black part of the GUI are now grey and the background of not 16:9 and not HDR videos is grey. If I force the use of the 16-235 colorspace it works, but I lose the benefits of HDR videos.

I tried to reboot, but it didn’t solve the problem.

Did I miss something when I updated ?

#2

What? HDR videos use a 16-235 range just like any other video.

#3

Ok, but I do no want to force the limited colorspace since it worked before the update. Anyway, I’m downloading the vero3-mediacenter-osmc armhf 18.2.0-6 maybe it will solve the problem.

#4

No, it won’t. You need to set limited output if using a normal TV, (ie not a PC monitor)

#7

I have a Sony 65AF8 TV. And it worked like a charm before the update.

#8

How were you setting full-range? IIRC there wasn’t a GUI setting for it.

#9

The limited colorspace option was there before the update in settings/system/display.

#12

OK, let me check what exactly that was doing, but I’m sure it wasn’t doing something rational otherwise we wouldn’t have changed it. By rational, I mean it was changing the signal but not the metadata or vice-versa.

With this update, the best setting should be limited range (aka 16-235). Your TV probably doesn’t support full range with YCC anyway. Please try and let us know what happens.

#13

The TV (Sony KD 65AF8) has a 10 bits oled panel and covers 99% of the DCI P3 colorspace. Hope it helps.

#14

The ‘range’ has nothing to do with the capabilities of the display. It’s just about how the colour values are encoded in the video signal. A normal video signal encodes 16 as black and 235 as full red, green or blue.

TVs understand this and interpret 16 as pixel off and 235 as pixel full brightness (or 64-940 when the signal is 10 bit). You are not losing anything by setting limited range, and you will not get correct colours if you set full range as you have discovered. That’s why the picture is washed out.

#15

Thanks for the explanation. So I enabled the limited colour range, and the HDR videos look like before.

I’m French, and the labeling for this setting is misleading (it talks about color space, not color range), but I should report it to the Kodi team.

1 Like
#16

Do you have force 4:2:2? I still have the problem with the letterboxs. There dark grey. I do not have this on my Shield.

Video Info:
Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings : CABAC / 5 Ref Frames
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2 h 32 min
Bit rate : 10.8 Mb/s
Width : 1 920 pixels
Height : 808 pixels
Display aspect ratio : 2.40:1
Frame rate mode : Constant
Frame rate : 24.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.290
Stream size : 11.5 GiB (88%)
Writing library : x264 core 157 r2935 545de2f
Encoding settings : cabac=1 / ref=5 / deblock=1:-3:-3 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=24 / lookahead_threads=4 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=2pass / mbtree=1 / bitrate=10800 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=3:0.80
Default : Yes
Forced : No

#17

Also have macroblocking. Which I also do not have on my shield.