[SOLVED] HDMI Passthrough not working after latest update


just updated my vero today (rc2 newest) and hdmi passthrough is not working anymore. I didn’t change any setting. Reboot didn’t help. Raspipi2 with older osmc release rc2+ works…

Any ideas?

Seems to be a software issue…

i could solve it - has the last update brought new audio options… what i did was:

reset audio options in systems menu - didn’t help
restartet update manual from command-line again (nothing new added) - helped
(former update was run via kodi gui) - seems that from command line something important is done - which is missed in the gui
went to audio in systems - did a reset and now there is true HD and DTS HD pass through support visible
enabled everything again and now it works fine…

Running an update from the command line won’t get any more osmc packages that checking via the GUI, so that is only a coincidence.

I would say that either your guisettings.xml got corrupted, or something changed in the settings in Kodi between builds - in both cases the solution is to exit from kodi, delete guisettings.xml then go back into Kodi. (Remember to change to expert settings as well so you see all the options)

ok, i will check after the next update - now everything works fine - cool device