[SOLVED] Http status code 503 while downloading addons

Hi!

I just got my Vero 4K+ in the post but I am unable to download addons. I have updated osmc to the latest version (juni 2020). Just fresh out of the box the version was like from november 2019.

It seems as the sha256-file is missing from the repository or something is really wrong.

2020-07-09 19:20:49.147 T:4068569088 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 503
2020-07-09 19:20:49.147 T:4068569088 ERROR: CCurlFile::Open failed with code 503 for http://download.osmc.tv/kodi/addons/leia/script.skinshortcuts/script.skinshortcuts-1.0.17.zip.sha256:
2020-07-09 19:20:49.148 T:4068569088 ERROR: Open - failed to open source http://download.osmc.tv/kodi/addons/leia/script.skinshortcuts/script.skinshortcuts-1.0.17.zip.sha256
2020-07-09 19:20:49.149 T:4068569088 ERROR: Failed to find hash for http://download.osmc.tv/kodi/addons/leia/script.skinshortcuts/script.skinshortcuts-1.0.17.zip from HTTP header and in separate file
2020-07-09 19:20:49.149 T:4068569088 ERROR: CAddonInstallJob[script.skinshortcuts]: failed to resolve addon install source path
2020-07-09 19:20:54.358 T:4068569088 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 503

Question: will backup and delete of /home/osmc/.kodi solve this issue?

Anyone?

1 Like

This one is a bit of a mystery. Please describe exactly what you were doing to get the error. Please also provide us with full logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Every time I try to set up the menu customization option, the install fails, and on a 3 B+ with a Samsung 64gb SDXC card, the button does nothing. I have tried multiple different Raspberry pi 3B+'s and sd cards to no avail. Tests were done on both ethernet and wifi.

Setup:
Pi 3 B+ with fresh osmc install
32 GB SDHC Sandisk ultra card
Also tried a 64gb SDXC Samsung card.

Regular Log:
http://paste.osmc.tv/cihecubuyi

Debug Log:
http://paste.osmc.tv/olawapawod

@SpyGuysGaming
@OsmcUserSweden

Seems there might be an issue with one download server. I guess problem will be solved later by @sam_nazarko, stay tuned.

1 Like

Thanks for the info.

This should now be resolved.

https://status.osmc.tv/incidents/rpcwn8nhhjbd

2 Likes

Thank you!

Thanks for the quick resolve!

1 Like