Solved:HTTPS failure on website

Tried to buy the vero v and got this when I hit the website:

||You’ve enabled HTTPS-Only Mode for enhanced security, and a HTTPS version of is not available.||

The double pipe marks are just my way of “surrounding” the error message.

No mention of errors on the forum so I am betting it has something to do with firefox 119.0.1 which was latest as of 5 days ago. Usually it is just a version issue (and usually with firefox) but my curiousity is piqued!

This occurs with both the vpn on and off…most interesting.

Really posting here in case someone has had the same issue and was waiting for it to clear or has fixed it.

Heh, its probably me being too crazy with security. :grinning:


Works for me.

Namecheap currently doesn’t support HTTPS requests for redirects and I didn’t want to use up a whole Let’s Encrypt environment for just one redirect, but looks like I should do this.

For now you can click here: Shopping bag – OSMC

I will fix the issue properly shortly.

Thank you Sam. That was very nice of you!

As luck would have it, life has gotten in the way…again. sigh. So I won’t be ordering it at the moment. Grrrrrrrrrr.

Thank you again for your effort!

Should work fine now – I deprecated the buy domain for now and just link directly to the order link. Will add an nginx redirect for shortly.

Thanks for the report.