[Solved] I can't get Tranmission to work

I have been reading some posts like this here, but any of them have a valid answer to my problem. I have followed this tutorial in order to install the daemon, changing where appears user pi with osmc.

Also, I have modified “/lib/systemd/system/transmission-daemon.service” to change the user to osmc. And I still get the permission problem.

If I change the ownership of bookkeeping folders the daemon isn’t able to get started.

I can’t write neither read, because the daemon through the web interface isn’t able to check the data that I have already downloaded.

I’ve read that Deluge is available on the app store , but as long as I’m runing Alpha 4 on rasp2, I don’t have acces to that option. However, I would prefer to get transmission working than Deluge.

Has someone managed to get this solved? Could him post the way he did that?



Have you searched the forum for this problem?
It sounds very similar to https://discourse.osmc.tv/t/solved-cant-get-around-permission-denied-in-transmission

I’m really against the what seems common practice of adjusting the user within the startup script, it’s much simpler and safer to add the debian-transmission user to the osmc group using the below code:

sudo usermod -a -G osmc debian-transmission

That should allow everything to work, you can skip steps 4 & 5 of that tutorial unless you wanted to change the nice level of the service in which case the code would be:

sudo nano /etc/init.d/transmission-daemon

Then as per the instructions:

line 29: "start-stop-daemon --start " to "start-stop-daemon --start --nicelevel 5 "

Hope that helps.

I also have tried that, but it’s still not working. Even more, when I try to access to the web interface it returns a 403 error (Forbidden).

I think that there’s something that I’m doing wrong, but I can’t figure what because as I have said, the same method on Raspberry Pi B+ with raspbmc it worked great.

I’m going to do a clean install and use the usermod method only, and post here everything I do in order to detect the problem.

Thanks for answering dude

Yes, that’s one of the first posts that I saw, but it didn’t solve anything

Okay, I’m still getting the same error.

What I’ve done is:

  • Install Alpha 4 with the Windows Installer for OSMC on an SD for a RaspberryPi2

  • Plug it in into the raspberry

  • Power on raspberry and wait until the OSMC menu screen appears

  • Introduce the following comands

    sudo apt-get update
    sudo apt-get install transmission-daemon
    sudo /etc/init.d/transmission-daemon stop
    sudo nano /etc/transmission-daemon/settings.json
    sudo /etc/init.d/transmission-daemon start
    On the .json file I only editted download-dir, rpc username and password and set whitelist to false
    I added a magnet link from a torrent with tons of seeds, and I get this

    I have tried using the comand

    chmod -R 777 /media/TOSHIBAEXT/Downloads/Transmission
    but it solves nothing

Ok, as long as you’ve run the command

sudo usermod -a -G osmc debian-transmission

I can’t see any reason it wouldn’t work as I do the same thing near enough every time I install.

One thing I do differently is I mount my HDD in my user folder (/home/imac/HDD).

Can you confirm the line you’ve used in the fstab to mount the drive?

I introduced the command usermod comand between

sudo nano /etc/transmission-daemon/settings.json


sudo /etc/init.d/transmission-daemon start

I don’t use any comand to mount it becase OSMC do it automatically when the system turns on, as raspbmc did.

I also have thought about the problem could be on the way the HDD is mounted, but I can erase and rename files from SSH, so probably the problem isn’t here. My HDD is a NTFS formated drive, 2TB size, and connected through a powered hub usb to the rasp.

See here, media directory gets wiped every boot, I’d recommend manually mounting your drive so it’s permissions remain

Could you tell me what line should I use to mount the HDD?
I only use


to mount a usb device that I plug in after turning on the rasp, but it gets devices mounted on /media/.

Finally, mounting the HDD on /mnt/ has solved the problem


Happy days.
Now you can use Transmission to legally download Linux distros :smiley:


1 Like

I’m dealing with the same problem as you are. Do you a good tutorial for mounting to /mnt/?

Okay I had the same issue as ever one else but think I have sorted it. My HDD was auto mounted to /media/Seagate so every thing I tied failed. Changing usernames to osmc did nothing, neither did usermod.
Started with a fresh install of osmc, then installed transmission.
All I had to do was change the mount point. I did sudo umount /media/Seagate. Then sudo mkdir /mnt/HDD, then manually mounted the HDD with sudo mount /dev/sda1 /mnt/hdd. Changed the Json file to point to the new mount point and it worked!
Finally i chanhed the fstab so it would auto mount correctly. /dev/sda1 /mnt/hdd ntfs-3g defaults,auto,uid=1000,gid=1000, 0 0
Downloads don’t seem to be as fast as using a standalone pi for torrenting but does the job!
Hope the above makes sense.

Same problem here but not with an external drive. I installed then configured Transmission as explained in this thread. I choose /home/osmc/Movies as download path and I get the exact same error though. I chmod’ed to 777 but it was useless. Any idea. Thanks :slight_smile:

This seems to have fixed it for now :smile: Great community