[Solved] IR Remote issue


#1

Would anyone be up for helping a linux newb figure this one out?

Rasberry Pi 3 B+, with updated OSMC Ver 2018-08-2, Kodi Ver 17.6 and a Justboom Digi hat. I got everything working great except for IR remote.

The hat came with a IR receiver and install instructions online. I installed it onto the hat as instructed.

I found my IR transmitter in a list in OSMC, so set that as the IR to use. But, it does not work. I saw a note about LIRC not working with HiFiBerry but that is not what I have. However, when I set up LIRC, I lose my Digi hat connections.

Justboom was contacted but not enough info for my newb level. The two pieces of info I got were:

  1. “I would imagine it is because lirc is configured to use the same pins as the Digi HAT for your remote. Is there a configuration you can change for the remote in the osmc settings?”

  2. “Not sure with your remote. You would need to override the GPIO pins that the remote is set up to use in the profile for your remote”

I have no idea what that means. It seems to me that if they supplied an IR receiver, I should be able to make it work. (They state theirs and also the OSMC IR remotes would work)

I did find another link tonight, but I’m confused about it showing how to configure LIRC which seems to conflict with their statement #1. Maybe I should just try to muddle through that anyways?

So, if someone knows how I can get my IR remote to work and has lot’s of patience, I thank you.


#2

So you wrote the was instructions online? Maybe share the link and it is easier to help you.
Does the instruction tell you which GPIO to use for the IR receiver? If so you need to configure them in MyOSMC - Pi Config


#3

Thanks. I put in two links now. If I’m understanding correctly, GPIO pins are on the Pi board? This IR is installed on the hat, so I think that’s different?


#4

Well the IR receiver is connected via the hat to the Pi GPIO.
From the instructions it says dtparam=gpio_in_pin=25 so go to MyOSMC - Pi Config - Hardware Support. Activate LIRC GPIO support and set the “in” pin respectively and set that pin respectively.


#5

Thanks, I’ll have a look. It’s late here now so will have to do another day. :slight_smile:


#6

Ok, I finally had a window of time to work on this more.

Wow, that was a lot of time, research, and stumbling. (As in many many hours) All just to get my WD Live remote unit working with Raspberry Pi and JustBoom Digihat. But how sweet it is now. :slight_smile:

I thought I would overview the procedure so that I can contribute back to this forum. Just in case there are any others that would like to know how to get an IR remote working for this setup. (It’s possible that it may only work on this particular Pi model, Ir Remote and version of OSMC, etc.) Disclaimer: This is what worked for me. If there are any other issues anyone has, sorry, I do not have any more info and it is at your own risk.

  1. Decide how you will work with terminal on OSMC. Although the terminal can be accessed on the Pi and OSMC itself if one has a keyboard and mouse, I found out that if you have a Lan connected to your router from the Pi, along with other computers on the same network, you can access the Pi remotely from another computer. That made it way easier to enter text on the terminal because you can copy and paste directly from website info. So much easier than entering it all manually as one little mistake can make it not work. For that I installed software called ‘Putty’ on my windows 7 desktop. (https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html)

You will need to find out your ip address for your Pi and then enter in the Putty software. Find that on My OSMC home page with the Network icon and Wired listing.

SSH has to be enabled on OSMC to do remote work. You can check and set this on My OSMC home page with the Services icon. If you don’t have it, this worked for me to install/reinstall using terminal:

sudo apt-get install --reinstall ssh-app-osmc

  1. You have to make sure that LIRC is installed and working with OSMC on your Pi. I followed the instructions on the JustBoom site for this. https://www.justboom.co/tutorials/configure-justboom-ir-remote-lirc/ (At least up to Step 5. Step 6 did not work for me but it turned out not to matter.) These instructions appear to be intended for their own brand remote which is why I did not originally think it was something I had to follow for my WD Live Remote device setup. They also state Raspbian O/S and I have OSMC. Regardless, apparently seems to be the base set up for all IR remotes. Btw, a great many remotes are already listed in the remotes set up on the home page of OSMC. If yours is not listed, there are also write ups out on the web on how to do custom remote installs but you can research that for yourself. I did not need to do the ‘training’, I’m guessing because my WD Live Remote was already listed.

  2. When I did the sudo reboot, my WD Live IR remote worked along with 5.1 sound and everything else as well.

Hope this helps someone, cheers, m.

Update 020319:

My OSMC crashed and the sd card burned out as result. So, got a new one and downloaded the latest OSMC. 2018.12.1. In this version it was super easy now to get the WD remote working. Didn’t have to do much at all.
I selected the WD Live remote in My OSMC/Remotes by scrolling down to it and confirming. Then went to My OSMC/Pi Config/Hardware Support and changing the gpio_in_pin to 25 and ok. Don’t forget, have to reboot pi to get settings to take place. That’s it, works fine.