[SOLVED-ish with workaround] Transmission app nonexistent

Hi everyone!

I spent the last 5 hours trying to get transmission running on my rPi 3 with osmc, but have failed miserably.
First I just went to the app store and installed transmission, but I couldn’t find it anywhere afterwards, I even tried rebooting a few times just to be sure, but still nothing.

After that I decided to use putty and install it manually. But now the strangest thing has happened.
I used
sudo apt-get install transmission-cli transmission-common transmission-daemon
to install everything (got that from a tutorial, another one before that just had transmission-daemon, but since this one installs more I figured I should show this one).

Then I went on to stop transmission before configuring, using the command
sudo /etc/init.d/transmission-daemon stop.
This gives me the following error:
“sudo: /etc/init.d/transmission-daemon: command not found”

When using cd to browse into the folders it turns out there is no folder called transmission-daemon inside init.d…

I’d just like to be able to use transmission, sending all the downloads to the (always mounted) external hard drive, nothing fancy.

Does anyone have any tips on how to get this to work?

Thanks in advance!

EDIT: I just tried running the same install command again, and am getting another error.
I can’t get putty to copy text, so I’ll just try to upload the picture.

Things on your system are now a little … let’s go with “confused” … because you have tried to install both the OSMC store version ("armv7-transmission-app-osmc, version 2.8.4-11) and the normal “RPi” one.

As to your original problem - no idea; don’t use it myself. But as to this, remove what you have tried to install; run “sudo apt-get autoremove” to clean up any automatically installed packages; remove the OSMC store version (probably best to do that using the GUI). Then start again with the OSMC packaged version … and hopefully someone will chip in helpfully telling you where to find it once it’s been installed :slight_smile:

Oh, and PuTTY usually automatically copies what you select - just select what you want to copy with your mouse (text will go inverse colours - black on white in your case) and as soon as you release the mouse button that text should be in your copy buffer.

As THEM wrote suggest you uninstall everything you installed manually and rely on the app store version.
Also just for your information OSMC doesn’t use the init.d system to manage services but systemd instead. You manage services with systemctl.

well I just ran the autoremove command from the terminal, and this is what it hit me with:

osmc@osmc:~$ sudo apt-get autoremove transmission-cli transmission-common transmission-daemon Reading package lists... Done Building dependency tree Reading state information... Done Package 'transmission-cli' is not installed, so not removed Package 'transmission-common' is not installed, so not removed Package 'transmission-daemon' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. osmc@osmc:~$

I uninstalled transmission from the appstore after that. Then rebooted and installed it again. After another reboot (just to be sure, I know linux machines seldom have to reboot) I still can’t find it.
The funny thing is that I did install samba from the app store, which runs perfectly (I also can’t find any config menu for that one, but at least it does what it should)

Anybody know where transmission should pop up and/or what I’m doing wrong?


EDIT: When going to the services menu in My OSMC, it says that Transmission Client is running, just llike samba and ssh.

How are you searching for it?

first do:
sudo apt-get install locate …

Then do:
sudo locate transmission-daemon

This should make the finding stuff more easy …

Also you can check if the process exists by typing:
sudo ps -e | grep transmission

If this gives output the daemon is installed and running.

If this fails:
Make sure you removed the transmission daemon by typing:
sudo apt-get -y remove transmission-daemon

No go back to the osmc-store remove transmission there too …
Then reboot and reinstall from the osmc store…
Now let me know what happens or what you found…

Ow and by the way: if you are running an X server with lightdm make sure you disabled all of that before installing anything from the osmc store because it screws up the system.

Hope this helps

The Transmission GUI is accessible via Internet browser: http://ip_of_pi:9091/

1 Like

Alright, so I tried the locate and the ps command. There was no output for locate, ps gave me 540 ? 00:01:15 transmission-da.
I went to the address ooZee mentioned, that loads nicely, so it seems that transmission is at least installed somewhere.

So now the final question is: Where is the config and how do I edit it?

Hope anyone knows :slight_smile:
Thanks in advance!

There is a small wrench icon on the bottom left, There are the basic setup steps, like speed limitations, download folder etc etc

I’m getting more confused by the minute :’)

Transmission runs well (as seen above), but whenever I add a torrent it tells me that I have no permission to write on the external hard disk (where I want the torrents to go).

I read somewhere that this was a problem with the command-line-installed transmission (transmission-daemon) and that the one you install via the app store doesn’t have this problem.

But now when I run sudo apt-get -y remove transmission-daemon it just tells me that there is no such thing installed, from which I conclude that the only transmission running is the one I got from the app store.

Sooo… can I get transmission the permission to write on the external drive? I already tried that with init.d, but to no avail…

I’d start over with a fresh install of osmc now.
Nobody can ever know what you did at this point and as you messed with the commandline without knowing what you do and didn’t know how the app actually is accessible in the first place, you learned a lot with this install.

Backup your data and start over.

How is the hdd mounted?

Okay, I reinstalled osmc (all files were on the external drive anyway, so no need to backup) and installed samba and transmission via the app store.
Samba works fine (though one day I’ll probably want to change the password to something better than the standard ‘osmc’, how do I do that?).

Transmission works, but when I start a torrent, it still hits me with the permission denied error.

The HDD was already plugged in when installing osmc and most likely won’t be unmounted anywhere in the future.
Right now, it’s path is “/media/Seagate Expansion Drive” (the system did all that by itself).

How do I get transmission the required permissions?

At this point, now you seem to have your client problems sorted out, you could have other underlying issues causing your current problem.

If you log in (ssh) and type “mount”, what is shown on the line containing “/media/Seagate Expansion Drive”? There will be a load of things inside a pair of brackets at the end of the line - is the first one rw or ro?

If it’s ro, the drive has been mounted read-only for some reason. One common cause for that is insufficient power - is this drive externally powered or powered by your “RPi”?
(of course, if it’s rw then that’s not the problem, but let’s start with some basics :slight_smile:) …

I can both read and write on the drive using samba, but here’s the output for mount:

osmc@raspi:~$ mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=370540k,nr_inodes=92635,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /run type tmpfs (rw,relatime)
/dev/mmcblk0p2 on / type ext4 (rw,noatime,stripe=1024,data=ordered)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=23,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
/dev/sda1 on /media/Seagate Expansion Drive type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks)
sysfs on /sys/devices/system/cpu/cpufreq/policy0/scaling_cur_freq type sysfs (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=75108k,mode=700,uid=1000,gid=1000)

of which I think the part you meant is this:
/dev/sda1 on /media/Seagate Expansion Drive type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks)

The drive is plugged into the raspberry pi directly but gets its power from an external power cord.

I’m very sorry, I missed your saying that; also yes, drive is mounted properly (rw).

So, not that then …

At that point, my expertise runs out - it looks as though it’s something “Transmission” related and I have no knowledge of that at all I’m afraid - sorry :frowning:. I’m sure someone else will contribute some other useful suggestion though.


1 Like

sudo /etc/init.d/transmission-daemon: command not found

Where you doing it from the xterm on the osmc-box
after having installed X and a desktop environment?

Because then I have experienced this as well

In that case go to TTY or fix your PATH for root …
Its seems to be an issue in a graphical environment.

@THEM: Don’t worry! Something will probably turn up ^^

@ActionA: I scoured the forum for more options once more. Here’s what I did:

  • confirm that init.d didn’t contain anything transmission-related
  • open /lib/systemd/system/transmission.service to add the line User=osmc, only to find out this was already set as default.
  • unmount the external drive with umount, then mounted it again to /mnt/USBHDD (I read somewhere that osmc screws up the permissions when automounting).
  • edited /etc/fstab, added the line /dev/sda1 /mnt/USBHDD ntfs-3g defaults,auto,uid=1000,gid=1000,umask=002 0 0
  • rebooted
  • found out transmission still isn’t working
  • used chmod 777 on the entire drive (which I didn’t want to do in the first place)
  • rebooted again
  • found out transmission still isn’t working

I did everything from putty.

If anyone has anything I can try next, I’d love to hear it. I’m getting pretty frustrated that something so simple is taking so much time already… :frowning:

edit: I changed the download directory for one torrent to /home/osmc. That works just fine, which is good, but since the SD is only 8GB this isn’t a permanent solution… Any ideas?

Try making a link to the HDD from your home directory