SOLVED Kernel failure after update

@popcornmix @sam_nazarko

Got a kernel failure in my rpi2. Kodi wasnt playing anything.
Had to cut the power 5 times today.
Now I restarted and killed kodi. No freezing so far

Debug logs ?

Are you overclocking ?

Here is the kodi log when that happened. I was watching a show but the last 4 times it freezed kodi wasn’t playing anything.

I was using overclock 1000 from osmc profile. Then as you can see in log, I changed to 900 (normal) but didn’t restarted

‘arm_freq’: ‘1000’, ‘over_voltage_sdram’: ‘0’, ‘core_freq’: ‘500’
I see sam PRrd this. Maybe it’s related?

[package] [mediacenter-addon-osmc] Make the higher profile for Pi 2 overclocking more reliable by using 450Mhz as sdram_freq

Started to run kodi at 08:56:30, it’s 10:29 now and no freeze so far.

I think it was the overclock setting that was 500 instead of 450

Yes, we have found that a lot of Pi 2’s are not stable with sdram >= 500 Mhz, and cannot clock the sdram as fast as most Pi 1’s without crashing.

This includes my own Pi 2 which will freeze within half an hour on our current Turbo preset, so in the interests of stability we are dropping the sdram frequency to 450 for the Turbo preset in the next update. (This will not affect already configured speeds, but next time a user changes to something else and back to Turbo it will be the “new” Turbo setting)

With arm=1000, core=500, sdram=450, over_voltage=2 so far my Pi 2 has been completely stable.

ok! thanks! Will close it