[SOLVED] Kodi freeze during a few seconds before playing since upgrade to buster

Or an add-on, more likely.

I suspect this as well but I would probably start by taking the old .kodi folder and just remove .kodi/userdata/guisettings.xml to see if the issue is there (mediacenter must be stopped first).

Might also take a look in passwords.xml to make sure there is nothing off there.

Same issue with guisettings.xml renamed (yes, i stopped mediacenter service before), and i don’t have any passwords.xml file.

I’m gonna try with disabling add-ons .
EDIT : disabled almost everything (except what would be needed by kodi), and it didn’t help.
I don’t use a lot of add-ons anyway.

I’m wondering if trying the 4.9 kernel would help.

Problem solved by cleaning my /home/osmc/.kodi/temp folder once i stopped the mediacenter service.

Basically, i started from scratch and copied back more and more from my userdata folder.
Once the userdata and its neighboor addons folder were back to original, the only difference was the temp folder.

1 Like