[SOLVED] Kodi image cut at borders and too bright

Hello,
finally I had the change to buy a Raspberry pi 4 8 GB, so I installed OSMCS 2022.03-1, which seems to work but I’m facing two little problems:

  1. the image doesn’t entirely fit the screen;

  2. the image is too bright.

For comparison, I’ve attached two screenshots: the first is OSMC 2022.03-1 running on Raspberry pi 4 (OSMC stock version, no addons, no mods of any kind except for localization), the second is OSMC 2020.11-1 running on my old Raspberry pi 3 B+ with the right image (centered and with correct brightness).

What can I do to fix this odd behavior of OSMC 2022.03-1 on Raspberry pi 4?

Thanks in advance, Kranz

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

What resolution have you set on the GUI? I would assume your TV supports different Brightness/Contrast Settings for each resolution

Hello fzinker,
first of all, thank you for your prompt answer :grinning:

I don’t think is a TV problem (and old Samsung fullhd), because I tried using the same HDMI input for Rpi3 and Rp4 (obviously shutting down the Rpi3 and the TV, phisically disconnecting the Rpi3 and then connectining the Rpi 4 on the same HDMI input), so the TV settings are exactly the same for that port wit both devices.

Config.txt files are nearly the same for OSMC with Rpi3 ancd OSMC with Rpi4 :

Rpi4 config.txt

[pi4]
dtoverlay=rpivid-v4l2
arm_64bit=1
kernel=kernel.img
[board-type=0x0e]
dtoverlay=vc4-kms-v3d,cma-256
[all]
dtoverlay=vc4-kms-v3d,cma-512
disable_overscan=1
start_x=1
disable_splash=1
disable_fw_kms_setup=1
hdmi_ignore_cec_init=1
include config-user.txt
[pi02]
dtoverlay=vc4-kms-v3d,cma-256

and config-user.txt is:

sdtv_aspect=1
start_x=1

Rpi3 config.txt

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
gpu_mem_256=112
gpu_mem_512=144
sdtv_aspect=1

My impression is that the new kms video driver for Rpi4 manages differently the (same ) hdmi port, because the OSMC installed on Rpi4 is a fresh install without any customization like calibration so changing TV settings will probably breaks the image with my Rpi3.

Ah, gui resolution is 1920x1080p @60 Hz with Rpi3 and Rpi4, limit GUI resolution set to AUTO.

Kranz.

  1. It could be that you (wrongly) configured overscan on the Pi3
  2. As the Pi4 would sent different resolution and Hz the overscan would be different

If you want to investigate upload logs either via MyOSMC or grab-logs -A from both Pi3 and Pi4 and share the URLs

Look at the manual of your TV to find where the overscan settings are and check to see in your TV how it is currently configured. If you don’t have the manual then you can look at the back of your TV to find the model number and then google "samsung <model number> manual". Alternatively you can google "samsung how to disable overscan" but the results will likely be varied as where this setting lives and what it is called can vary over time.

Your wasting your time looking for a problem in the OS when this is normal default behavior on most TV’s when you hook a computer up to them and it isn’t a “problem” you just need to switch the setting in your TV.

Regarding the brightness issue try this…
https://discourse.osmc.tv/t/dvd-playback-on-pi4-has-pale-colours/92642/3
Using HDMI 0 on the Pi 4, rather than HDMI 1 solved a similar issue for me.

Hello,
chianging hdmi port and following the advice of to set my Samsung TV Picture Options in " “Screen Fit” mode finally solved the overscan issue.
The excessive brightness was due to the infamous “Dynamic Range” default, so switching it off returned the images with correct brightness :grinning:

I’ve just tested OSMC 2022.03-1 with my Raspberry pi 4 and I haven’t noticed any particular issue. My testing was narrowed to 1080p (and lower) resolution, no 4k videos because my tv is ten years old and that resolution is usupported.

I’ll mark this topic as [SOLVED].

As usual, thank you a lot for the support.

Bye, Kranz