[SOLVED] LIRC Woes: Single Button Press, Mutliple Activations

I am having an interesting time getting my ir remote and dongle to work properly. Here is the hardware:

Remote Control: Hewlett Packard TSGH-IR07 (RC6 remote)
USB IR Reciever: TSDX-IR14
Raspberry Pi 3B running the Jun 7, 2018 build of OSMC.

The remote and the receiver a found without any problem by the system. I was even able to use irrecord to create my own conf file. It can be viewed here: HPTSGH.conf Upon reboot, all the buttons were recognized but there was a small problem. No matter what button I would push on the remote, I would press it once, and it would send multiple presses. irw would show that each time I pressed a button on the remote, 3 and sometimes even 4 presses would be registered.

After multiple searches, I have found that only two things seem to stop this behaviour:

  1. Boot to OSMC and use Putty to access it from another computer. Run sudo systemctl stop lircd_helper@lirc0 I know this stops the lircd_helper service. The remote runs beautifully then. This is not a solution. It has to be done every time I run my OSMC install.

  2. Followed the solution provided by Joakim_s in this post: https://discourse.osmc.tv/t/pi2-b-with-rc6-remote-duplicates-key-events/4946/17. There I installed ir-keytable and then created a script to have it run on boot. This worked, somewhat. When you are pushing the multiple buttons one after the other, there is a delay from when the button is pushed to when it is shown on the screen.

I am at wits end and I do not know how to proceed. Please let me know if any further information is required. Thank you for your time!

Is it not possible to use systemctl to disable the lircd_helper service?

If not, you could also try adding the systemctl stop lircd_helper@lirc0 line to /etc/rc.local, or create a cron job that runs this command every minute (harmless if the service is already stopped).

You should be able to mask the service.

Service lircd_helper@lirc0 has a BindTo= link to eventlircd.service. Iā€™m unsure about adverse side-effects but you can disable eventlircd.service that will then prevent lircd_helper@lirc0 from running.

Unfortunately stopping the eventlircd.service at start will prevent the it remote from working at all. While learning how to create a cron job to stop this service after boot, I noticed some errors in the system itself. So I did a re-install with the latest version (the install I was running was almost 2 years old), and lo and behold, the problem was fixed.

Thank you all for your help.

1 Like