[SOLVED] My HDD do not auto mount on OSMC

#1

Hi,

I recently had to reinstall OSMC on my raspberry. I don’t know why but suddenly my raspberry refuse to launch, the screen stayed black with “no signal”. So i decided to do a new installation from the OSMC automatic installer. All went ok but when i launched OSMC for the first time, after the installation wizard, when i plugged my external HDD (with his own power supply), nothing appeard ! In the file sections, my HDD do not appear on “auto-mounted device”.
I search on forums before to post here but everywhere i find some linux commands like “sudo…” but I never do this before and i just plugged my HDD to have it in auto-mounted devices…
What did i missed this time ?
Is there somewhere something to do on OSMC to have USB drives detected ?

Thank you all for help

#2

Have you tried plugging that drive into a PC to ensure that it is readable? Does the drive have its own power source or is it powering itself from the USB port?

Also if your talking about the Video>Files section you might have to add it as a source for it to show up there. If you go to the settings and click on the “File Manager” then you should see any automounted drives without doing anything extra.

#3

Yes the HDD is functionnal on a PC and it has it’s own power source (it is a WD MyBook 1,5To) ; i used it on OSMC before without any problem.
I agree, it seems to me that HDD should be present on automounted drives… but it is not. When i plugged the drive, i no longer have notification that the drive is mounted like i used to have it on my previous installation of OMSC.
I tried with an USB key without any problem : notification appear and the key is accessible but it do not work with the HDD !
I don’t understand where is the problem !

#4

I would try running a drive scan/repair on the PC. I have heard that there can sometimes be some kinds of corruption that can cause the drives to not be readable in Linux even though they look fine in Windows. (assuming your using NTFS or exFAT)

#5

Tried… found errors… solve errors… but not the problem.
But I guess i have found the problem : BiLocker ! BitLocker seems try to crypt my USB drive (without any permission or warning)

Now i have to find how to stop Bitlocker !

#6

I confirm Bitlocker was at the origin of the problem. I could decrypt all files and now OSMC see my HDD.
Now, why bitlocker decided to crypt all my files without any autorisation, that is another story !

Thank all for help.