[SOLVED] My RF remote has stopped working after migration to Kodi v17

My c120 Air mouse has stopped working when I switched to from OSMC2017.1.1 “Kodi v16.1” to OSMC 2017.2.1 “Kodi v17”. the issue is that the all keybord key and the up /down /home/R-Mouse/Back button no longer work, except the gyroscope move of mouse cursor are getting valid signals.


  • I unplug the USB dongle & Plug it in after booting and run

dmesg | paste-log

Here’s a log http://paste.osmc.io/sehixokalo

[   35.724925] usb 1-1.4: new full-speed USB device number 5 using dwc_otg
[   35.841239] usb 1-1.4: New USB device found, idVendor=1d57, idProduct=ad03
[   35.841271] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   35.841288] usb 1-1.4: Product: RFIC-MOUSE
[   35.841304] usb 1-1.4: Manufacturer: FREEWAY TECHNOLOGY
[   35.841319] usb 1-1.4: SerialNumber: RFIC-KEYBOARD
[   35.858750] input: FREEWAY TECHNOLOGY RFIC-MOUSE as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.2/0003:1D57:AD03.0001/input/input0
[   35.921185] hid-generic 0003:1D57:AD03.0001: input,hiddev0,hidraw0: USB HID v1.01 Keyboard [FREEWAY TECHNOLOGY RFIC-MOUSE] on usb-3f980000.usb-1.4/input2
[   35.929620] input: FREEWAY TECHNOLOGY RFIC-MOUSE as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.3/0003:1D57:AD03.0002/input/input1
[   35.930737] hid-generic 0003:1D57:AD03.0002: input,hidraw1: USB HID v1.01 Mouse [FREEWAY TECHNOLOGY RFIC-MOUSE] on usb-3f980000.usb-1.4/input3
[   36.000386] usbcore: registered new interface driver snd-usb-audio

It looks like it is a keyboard…


So, who can offer some advice on the easiest way to get my buttons working again?

1 Like

Same happens for me.

Here is my log: http://paste.osmc.io/dimigajeka seems similar to the OP’s

Some keys may have changed.

Use evtest to check output of each button and make sure keyboard.xml is set properly in Kodi. It may be necessary for us to change some button mappings.

a. Evtest shows the correct keys are received (see below), but the UI doesn’t repond to the key press:

For example (pressing Up and left):
Event: time 1486486043.478660, -------------- EV_SYN ------------
Event: time 1486486043.630669, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70052
Event: time 1486486043.630669, type 1 (EV_KEY), code 103 (KEY_UP), value 0
Event: time 1486486043.630669, -------------- EV_SYN ------------
Event: time 1486486044.038717, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70050
Event: time 1486486044.038717, type 1 (EV_KEY), code 105 (KEY_LEFT), value 1
Event: time 1486486044.038717, -------------- EV_SYN ------------

b. I am trying to find keyboard.xml under ~/.kodi/userdata/keymaps/ but the content of the dir is:

drwxr-xr-x 2 osmc osmc 4096 Dec 21 17:46 .
drwxr-xr-x 9 osmc osmc 4096 Dec 17 00:54 …
-rwxr-xr-x 1 osmc osmc 1169 Dec 20 23:56 appcommand.xml.bak.0
-rwxr-xr-x 1 osmc osmc 1862 Dec 20 23:56 mouse.xml.bak.0

Am I looking at the wrong place?

BTW - its not that some keys have changed. Except the OK button and the Air Mouse, all the other keys are dysfunctional.

Keyboard.xml is usually in /usr/share/kodi. If you want to override it you can create your own in userdata/keymaps.

There seem to have been a few changes since Jarvis:

commit 034cc0c6100a246e8fd8d54d0e9c8c05a3f4e17f
Author: Rechi <Rechi@users.noreply.github.com>
Date:   Sun Jan 29 12:31:45 2017 +0100

    Fix Trac 17273 by disabling lonpress-mapping in VirtualKeyboard

commit 5df8e1a8c586c67af068f1fdb37e069cda413c20
Author: Kai Sommerfeld <kai.sommerfeld@gmx.com>
Date:   Sat Dec 24 12:16:34 2016 +0100

    [PVR] Fix guide window: do not jump to grid start on channel group change; go to 'now' instead.

commit 2649355da8ab6e970b1d9cb7c29cc4886dc57558
Author: Ned Scott <ned@nedscott.com>
Date:   Wed Sep 28 17:02:21 2016 -0700

    minor keymap change
    
    As requested here: https://github.com/xbmc/xbmc/commit/9719da3ea8046d363f3ebf650368ce7ef0838ed3#commitcomment-19212541
    
    change control + arrow to alt + arrow, to avoid conflict on Mac OS X.

commit 779579cd9f36ad110e05bd75fafd7d911cacc42d
Merge: fb04fdf 9719da3
Author: Martijn Kaijser <martijn@xbmc.org>
Date:   Thu Sep 22 23:21:41 2016 +0200

    Merge pull request #10347 from NedScott/misc-keymap
    
    Miscellaneous keymap cleanup

commit 9719da3ea8046d363f3ebf650368ce7ef0838ed3
Author: Ned Scott <ned@nedscott.com>
Date:   Sat Aug 27 00:37:58 2016 -0700

    Miscellaneous keymap cleanup
    
    These are all the little things that didn't seem big enough for their own PR:
    
    Updated the header area to finally remove all those lingering XBMC references (some even mentioned the xbox!)
    
    touchscreen.xml - Removed two-finger-swipe-left = seek(-7). It will now always be "back". This was originally added when remote.xml used to do smallstepback, but JMarshall thought back should always be back, and I agree. I just forgot to change touchscreen.xml
    
    Joystick keymap had an unneeded < programs > section that was left over from a previous fix.
    
    Added a couple of mod-combo actions to keyboard.xml for the sake of users who can't use longpress (Flirc, etc).

commit e862109df76492b780f70faa9762f231d798c726
Author: ronie <ronie@users.noreply.github.com>
Date:   Mon Aug 29 21:32:58 2016 +0200

    [keymap] fix window names

commit 357dd016098729b49fc4591bdf341681aed0b5e4
Author: Rainer Hochecker <fernetmenta@online.de>
Date:   Fri Aug 19 13:16:08 2016 +0200

    remove longpress from left/right keys

commit f625dbfecd8687dee7d532391e29f23e990f3291
Author: Rainer Hochecker <fernetmenta@online.de>
Date:   Sun Jul 31 16:12:11 2016 +0200

    Pictures: trigger picture info on ACTION_SHOW_INFO

You can find the file on GitHub and see if you can find the commit that changed behaviour, assuming it is an issue with keyboard.xml.

I am trying to understand the dependencies and flow… so if evtest detects the correct key presses, but OSMC/Kodi doesn’t respond to anything, where should I look next?

Here is the abcd from evtest for example, but again, nothing happens on the screen:

Event: time 1486486602.971183, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70004
Event: time 1486486602.971183, type 1 (EV_KEY), code 30 (KEY_A), value 1
Event: time 1486486602.971183, -------------- EV_SYN ------------
Event: time 1486486603.107185, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70004
Event: time 1486486603.107185, type 1 (EV_KEY), code 30 (KEY_A), value 0
Event: time 1486486603.107185, -------------- EV_SYN ------------
Event: time 1486486603.755245, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70005
Event: time 1486486603.755245, type 1 (EV_KEY), code 48 (KEY_B), value 1
Event: time 1486486603.755245, -------------- EV_SYN ------------
Event: time 1486486603.955264, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70005
Event: time 1486486603.955264, type 1 (EV_KEY), code 48 (KEY_B), value 0
Event: time 1486486603.955264, -------------- EV_SYN ------------
Event: time 1486486604.387358, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70006
Event: time 1486486604.387358, type 1 (EV_KEY), code 46 (KEY_C), value 1
Event: time 1486486604.387358, -------------- EV_SYN ------------
Event: time 1486486604.571340, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70006
Event: time 1486486604.571340, type 1 (EV_KEY), code 46 (KEY_C), value 0
Event: time 1486486604.571340, -------------- EV_SYN ------------
Event: time 1486486605.211421, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70007
Event: time 1486486605.211421, type 1 (EV_KEY), code 32 (KEY_D), value 1
Event: time 1486486605.211421, -------------- EV_SYN ------------
Event: time 1486486605.395436, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70007
Event: time 1486486605.395436, type 1 (EV_KEY), code 32 (KEY_D), value 0

Kodi debug log
Then Kodi settings
Then keyboard/remote.xml

The log is full of this messages:

01:31:56.713 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 13
01:31:56.713 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 14
01:31:56.713 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 15
01:31:56.729 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 10
01:31:56.729 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 11
01:31:56.729 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 12
01:31:56.729 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 13
01:31:56.729 T:1959142320 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 14

Any idea?

Same here. I have a different remote (T3), but the receiver manufacturer appears to be the same (as it also presents as a FREEWAY TECHNOLOGY RFIC-MOUSE).

I have checked the debug kodi.log and there is absolutely nothing regarding keypresses when I press any of the buttons on the remote.

If it was just a keymap mismatch, I would expect at least some feedback (i.e. some buttons to work) as the remote also has a full keyboard, which should work universally.

Can anyone contact this manufacturer and ask them for a recommended keymap for Kodi Krypton?
I don’t have this remote, but I’m sure they can provide some feedback about how to get it to run under the new version of Kodi.

With evtest, irrecord and adjusting remote/keyboard.xml, you will surely be able to get it working.

Mine doesn’t have a clear manufacturer to contact. I have seen the same remote under various names and ‘brands’.

I have used it with Raspbian and Windows IOT as well, and it worked out of the box until the last update of OSMC/Kodi 17.

It looks like that:

The photograph doesn’t really help, as I don’t have one.

What we really need is logs and someone willing to do some work on getting it to work.

I notice your link to the image is a Shopify link, so it must be on sale somewhere. You could contact the seller and ask them for a keymap, particularly if they advertise Kodi v17 support.

Otherwise we just have to start bissecting commits

As I wrote, I have seen it in different shops under different names. I believe its an OEM Chinese set that is quiet popular for redistribution. Mine doesn’t have a brand printed on it.

I am happy to be the person doing the work you requested.

I’m having the same issue with T3 remote, stopped working after update to OSMC Krypton .
I’ve found this image on Kodi Forums, can’t tell if it’s of any use : https://goo.gl/u3mUW5
I’ll try to contact seller, but I doubt I’ll be successful over aliexpress. I’ve seen the same remote on Amazon though : https://goo.gl/b9ZRWZ

Air Mouse function works fine. I’ve used a following keymap ( http://pastebin.com/eb9fEvja )just to test something and as expected, air mouse stopped working, but OK and back button started to work.

I rolled back to OSMC February Jarvis release using my backup image , but I have another SD card for testing and am more then willing to pick up logs or anything necessary to get this working.

My apologies for rather lousy first post.

1 Like

I tried to compile a keymap.xml using this image


I’ve found this image on Kodi Forums, can’t tell if it’s of any use : https://goo.gl/u3mUW5


but nothing works

1 Like

Just to confirm that the problem is indeed in Kodi (and not a HID driver, for example), I opened a local console and there the QWERTY keyboard on the remote fully works as expected.

We haven’t changed LIRC or eventlircd, so that makes sense. Changes are likely in Kodi.

Here is a short history of changes to keymaps over the past year or so: https://github.com/xbmc/xbmc/commits/master/system/keymaps.

That may give some clues. I would start with the XML files at the earliest time of Jarvis, i.e. around December 2015 and go from there.

I tried replacing the whole /usr/share/kodi/system/keymaps directory with the one from the december 2015 and it does not work either. Also tried restoring the “Lircmap.xml” and “peripherals.xml” files just in case, without success too.

Any idea where else to look?

Unfortunately not.

Debug log from Jarvis vs Krypton might give clues as to how the presses are being interpreted now. Make sure the same settings are enabled, i.e. ‘remote sends keyboard presses’ in Kodi. From what we can see this only appears to be affecting a couple of remotes, so it’s likely some mapping has changed for these devices.

Should we provide logs here or ,since it’s related to KODI itself , we should head over to KODI forum with logs ? The latter makes more sense, I’m just asking in case you are interested in logs.

If to be provided here ,will taking logs like this suffice : reboot , press let’s say appx 10 buttons,take log (both in Jarvis and Krypton of course).