[SOLVED] "No Internet"

Hi All,

I’ve been running OSMC for years without issue. Last night I switched ISPs, I wiped my raspberry Pi and decided to just do a clean start. Unfortunately, now I’m having a nightmare of a time getting internet to the Pi (with OSMC).

LAN and WiFi are behaving slightly differently but each has IP address, subnet mask, Primary and Secondary DNA filled in, yet, show “no internet” next to Status.

The box is getting an IP as I can use Yatse remote and ssh into it just fine…net is working flawlessly on every other device (multiple laptops, my PS4, phones, etc…)

Thoughts?

Hi @jmadero,

Check that the gateway is set properly.

Hey @sam_nazarko

Looks fine to me. On my *nix box I ran ip r | grep default and compared that number to the number listed in my wired Default Gateway (disconnected wifi entirely) and they are the same…rebooted, still “no internet”

If you’re SSH’d in, then the quickest way would be:

sudo rm /var/lib/connman/ethernet_*
sudo rm /var/lib/connman/wifi_*

Sam

Deleted those directories, rebooted. Went back into Wired options in OSMC and now I see a new (not right) IP address listed and a new (not right) Subnet Mask listed, Default Gateway, Primary DNS, and Secondary DNS are all empty. Still “Status: eth0 (no internet)”.

I can still SSH into it fine: osmc@192.168.0.xxx, Wired IP in OSMC settings shows “169.254.xxx.xxx” - no clue how it’s getting that number.

That’s a private IP when DHCP fails.

How could you ssh in with 192.168.0.xxx?
What the output of ifconfig?

More not good news. I manually entered everything (IP Address, subnet, default, primary, secondary). No internet.

Then I rebooted the machine. When I went back into OSMC settings into Wired network options, all numbers are gone other than IP Address and Subnet Mask which have reverted back to the not good numbers…

I have to run to work and it’s Valentine’s Day so I’ll likely be working on this all weekend…7x internet speed isn’t super useful when my entire media center is borked :-/

If you’ve a USB keyboard, I’d suggest logging in via the command line and having a look there.
You can use grab-logs to save logs to an SD card.

IIRC you have to click Apply after entering the numbers. Just checking.

More interesting findings . . . still no net.

I can ping google fine:

Blockquote
osmc@osmc:~$ ping google.com
PING google.com (172.217.11.174): 56 data bytes
64 bytes from 172.217.11.174: seq=0 ttl=252 time=12.677 ms
64 bytes from 172.217.11.174: seq=1 ttl=252 time=12.597 ms
64 bytes from 172.217.11.174: seq=2 ttl=252 time=13.621 ms
64 bytes from 172.217.11.174: seq=3 ttl=252 time=12.436 ms
64 bytes from 172.217.11.174: seq=4 ttl=252 time=12.888 ms
64 bytes from 172.217.11.174: seq=5 ttl=252 time=12.592 ms
^C
google.com ping statistics —
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 12.436/12.801/13.621 ms

But when I try to do sudo apt-get update, failure:

Blockquote
osmc@osmc:~$ sudo apt-get update
Get:1 http://security.debian.org stretch/updates InRelease [4,465 B]
Err:1 http://security.debian.org stretch/updates InRelease
Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
Get:2 http://ftp.debian.org/debian stretch InRelease [4,465 B]
Err:2 http://ftp.debian.org/debian stretch InRelease
Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
Get:3 http://ftp.debian.org/debian stretch-updates InRelease [4,465 B]
Err:3 http://ftp.debian.org/debian stretch-updates InRelease
Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
Get:4 http://apt.osmc.tv stretch InRelease [4,465 B]
Err:4 http://apt.osmc.tv stretch InRelease
Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
Fetched 17.9 kB in 0s (257 kB/s)
Reading package lists… Done
E: Failed to fetch http://ftp.debian.org/debian/dists/stretch/InRelease Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
E: Failed to fetch http://ftp.debian.org/debian/dists/stretch-updates/InRelease Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
E: Failed to fetch http://security.debian.org/dists/stretch/updates/InRelease Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
E: Failed to fetch http://apt.osmc.tv/dists/stretch/InRelease Clearsigned file isn’t valid, got ‘NOSPLIT’ (does the network require authentication?)
E: Some index files failed to download. They have been ignored, or old ones used instead.

Net settings still says no internet…

What is output of

ifconfig
route
cat /etc/resolv.conf

Also please provide URL of grab-logs -A

Blockquote
osmc@osmc:~$ ifconfig
eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC> mtu 1500
inet 192.168.0.229 netmask 255.255.255.0 broadcast 192.168.0.255
ether b8:27:eb:43:6d:75 txqueuelen 1000 (Ethernet)
RX packets 410 bytes 79035 (77.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 559 bytes 86309 (84.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Blockquote
osmc@osmc:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default gateway 0.0.0.0 UG 0 0 0 eth0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
gateway 0.0.0.0 255.255.255.255 UH 0 0 0 eth0

Blockquote
osmc@osmc:~$ cat /etc/resolv.conf
Generated by Connection Manager
nameserver 68.105.28.11
nameserver 68.105.29.11

Log: https://drive.google.com/file/d/1HJahVyNHZHMmRfvWselRlg2lT0rrKRkn/view?usp=sharing

For me this looks like a https only issue which would indicate that your ISP is using a transparent proxy which mess up the service

Is there a workaround?

Could try to use a VPN.

Or ask your ISP to provide a proper internet service

Check first if you are behind a transparent proxy
https://isc.sans.edu/forums/diary/How+to+identify+if+you+are+behind+a+Transparent+Proxy/14647/

Quick google search makes me think this isn’t the case. I’m in the US - seems unlikely.

Have you seen the link that I added to my post?

Also what happens if you do wget https://cdimage.debian.org/debian-cd/current/arm64/iso-cd/debian-9.7.0-arm64-netinst.iso does it download the file? And is the MD5sum bb67b6aa7220e62a56e8d79155f660e6 ?

Downloads fine from laptop. Of course not from RPi as it’s not connecting to net right.

Hi,

Longshot here but it could be that only the dns is using a transparent proxy, I would try trying the dns servers in /etc/resolv.conf or via myosmc.

thanks tom.