SOLVED - No movies or TV after July Update

Hi, I just updated my OSMC Pi to the latest update. When it booted back up, Movies and TV were missing from the main menu.

I manually added Movies back by changing the source on the menu setup to be:
ActivateWindow(10025,“library://video/movies/”,return)

Now the menu item appears but there are not movies in any of the options.

I saw a post from December telling someone who had something similar to go into the Movies source, edit source and change it to Movies with the appropriate scraper. I did this (it had reset from Movies to None), but this doesn’t save now, it always resets to None.

My Movies/TV/Music are all on an NFS share on a Linux box (banana Pi) which is also where the MySQL library is held. I should add at this point that my Music works fine somehow. This is also NFS/MySQL.

Any ideas to resolve this?

Hi :wink:
I do have the same kind of architecture (several NFS server and 1 standalone SQL server)
When I’m facing this kind of issue, here’s what I do:

  • Video>Files
    could I browse the movies and TV show?
    If NO (very often); that looks like a NFS issue
    I check the sources (is the nfs share connection correct)
    then I check my NFS-server is properly configured

If Yes (It happens once to me!); that looks like a MySQL issue,

  • 1st does your SQL server still have some FREE SPACE
    I’m NOT kidding…it happened to me :blush:
  • 2nd does your kodi SQL-user have full access to the SQL server (creating Database)
  • 3rd did your SQL server is running…(not possible, but…)

to sum up:
check you can browse your NFS shares

If it’s your NFS, verify your NFS-server is running and not idling
If it’s not your NFS, verify your SQL-server : free space, privilege of the kodi-SQL user

Please, if it is a lack of free space, tell me… I would be feeling less lonely :smile:

Hi, thanks for your reply.

I have checked and I can access and play all of my TV and Movies through the “Files” browser in Kodi (from my NFS mounted share). All play fine, so I think that rules out an NFS issue.

I’ve checked the Banana Pi and can’t see any space issues. I’ve restarted the MySQL service, and also checked the status of it:

[info] /usr/bin/mysqladmin Ver 8.42 Distrib 5.5.41, for debian-linux-gnu on armv7l
Copyright © 2000, 2014, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Server version 5.5.41-0+wheezy1
Protocol version 10
Connection Localhost via UNIX socket
UNIX socket /var/run/mysqld/mysqld.sock
Uptime: 16 sec

Threads: 1 Questions: 110 Slow queries: 0 Opens: 570 Flush tables: 1 Open tables: 146 Queries per second avg: 6.875.

Not sure if that really shows anything useful. My music library is also on MySQL though, so I would have thought if it was an issue with that, my Music would not be available in my Kodi library? I’ve also double checked the AdvancedSettings.xml hasn’t been overwritten and still has the MySQL credentials in. Unless this has changed location with Kodi 15?

Any more ideas?

Ok,

It seems you checked NFS, if you can access everything, it seems obvious that it’s not NFS related.

concerning SQL… are you afraid of SQL?
NO! good answer :smile:
try to connect to your sql server, from an authorized console:

$mysql -u kodi -p kodi -h sql-server(of course, replace with the correct credentials…)
then display the existing databases with the query “show databases;”:
don’t forget the semi-colon “;” at the end of every query !!! (as I don’t know how familiar you are with SQL, command-line, etc… I’ll take you by hand)

Here is what it gives to me:[code]MariaDB [(none)]> show databases;

±-------------------+
| Database |
±-------------------+
| MyMusic48 |
| MyMusic52 |
| MyVideos90 |
| MyVideos93 |
| information_schema |
| mysql |
| performance_schema |
±-------------------+
7 rows in set (0.00 sec)[/code]you can see I recently updated the databases for kodi:
On the kodi wiki, you can learn the Version of databases : http://kodi.wiki/view/Databases/Versions
for kodi 15(RC1), you should see MyVideos93
If the database MyVideos93 is created, it should contains the required tables. If you want to be sure:use MyVideos93; show tables;
If there is any tables, you could verify these tables are not empty
this query will display the 10 first movies name, path and filename :

select movie.idMovie, movie.c00, path.strPath, files.strFilename from movie left join files ON movie.idFile=files.idFile left join path ON files.idPath=path.idPath order by movie.c00 asc limit 10;
DON’T FORGET to QUIT quit;

  • If you cannot access / show the good version / display some datas about your videos, this is related to the update and you’ll have to update again
  • from the GUI MyOSMC, update, check update, install update
  • or from the console :
    – “sudo apt-get update”
    – “sudo apt-get upgrade” (this one has the reputation to be not mandatory)
    – “sudo apt-get dist-upgrade”
    – “sudo reboot”
  • If you can access / show the good version / display some nice informations, this is not related to the update, but to the behavior of kodi.
    If so, please do the following :
  • connect ssh to your OSMC
  • chdir to ~/.kodi/temp
  • Videos > Files > any video file
  • key “c”, or anything to display the “infos” and add the movie to your database
  • then go back to your ssh console and please post anything SQL-related:$ cat ~/.kodi/temp/kodi.log | grep -i SQL | tail -20

You could at least try with the M$ method, delete and retry:
This means on your SQL-server, drop your MyVideos93 database and reboot your KODI.

BTW: you don’t have any other KODI in use on your network?

Hope it helps.

Odds are that the update to Myvideos93.db failed and left a corrupted database. try dropping myvideos93 database from MySql then restarting Kodi. The database update can take some time and Kodi may appear frozen during the process, just wait for it to complete.

Hi, thank you very much for your help guys! Yes I think you are correct on the corrupt database. I dropped MyVideos93 and started Kodi back up. After a long pause it’s now all working!!

Glad to you.

Maybe you can change your subject and add “SOLVED” somewhere in your title

The thread can be marked solved by using the check box on the post that provides the solution. See photo below…

Thanks guys, have done this now.