[Solved] One Vero4K+ updates to 2023-01, another one does not?

I have a really strange issue where one Vero4K+ updates to 2023-01 and another does not.

I almost always update via Manual Controls | Scan for updates in the UI since I never seem to trigger the notification.

This time only one Vero4K+ updated, the other one says “No updates available”.

So I logged in via ssh and tried sudo apt-get update

both Vero:s gives this so they are hitting the same mirror:

Hit:1 http://ftp.debian.org/debian bullseye InRelease
Hit:2 http://ftp.debian.org/debian bullseye-updates InRelease
Hit:3 http://security.debian.org bullseye-security InRelease
Hit:4 https://ftp.fau.de/osmc/osmc/apt bullseye InRelease

sudo apt-get dist-upgrade


0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

on both Vero:s.

The older one that actually updated to 2023-01 has a slightly longer list of packages it thinks I should autoremove.

Kernel versions are:
4.9.269-16-osmc #1 SMP PREEMPT Tue Nov 1 15:44:25 UTC 2022
4.9.269-21-osmc #1 SMP PREEMPT Sat Jan 7 03:47:42 UTC 2023

if I look at installed packages with sudo apt list --installed and the vero3 “section” has

vero3-bootloader-osmc/now 1.8.0-3 armhf [installed,local]
vero3-device-osmc/now 1.5.1 armhf [installed,local]
vero3-earlysplash-osmc/now 1.0.5 armhf [installed,local]
vero3-ftr-osmc/now 1.6.0 armhf [installed,local]
vero3-fwenv-osmc/now 2016.01-5 armhf [installed,local]
vero3-libcec-osmc/now 6.0.2-5 armhf [installed,local]
vero3-mediacenter-osmc/now 19.5.0-10 armhf [installed,local]
vero3-secureosmc-osmc/now 1.5.0-2 armhf [installed,local]
vero3-userland-osmc/now 2.0.4 armhf [installed,local]
vero3-wifi-osmc/now 1.7.0-2 armhf [installed,local]
vero364-image-4.9.269-16-osmc/now 4.9.269-16-osmc arm64 [installed,local]
vero364-kernel-osmc/now 3.9.253 arm64 [installed,local]


vero3-bootloader-osmc/unknown,now 1.8.0-3 armhf [installed,automatic]
vero3-device-osmc/unknown,now 1.5.2 armhf [installed]
vero3-earlysplash-osmc/unknown,now 1.0.5 armhf [installed,automatic]
vero3-ftr-osmc/unknown,now 1.6.0 armhf [installed,automatic]
vero3-fwenv-osmc/unknown,now 2016.01-5 armhf [installed,automatic]
vero3-libcec-osmc/unknown,now 6.0.2-5 armhf [installed,automatic]
vero3-mediacenter-osmc/unknown,now 19.5.0-15 armhf [installed,automatic]
vero3-secureosmc-osmc/unknown,now 1.5.0-2 armhf [installed,automatic]
vero3-userland-osmc/unknown,now 2.0.4 armhf [installed]
vero3-wifi-osmc/unknown,now 1.7.0-2 armhf [installed,automatic]
vero364-image-4.9.269-16-osmc/unknown,now 4.9.269-16-osmc arm64 [installed,automatic]
vero364-image-4.9.269-21-osmc/unknown,now 4.9.269-21-osmc arm64 [installed,automatic]
vero364-kernel-osmc/unknown,now 3.9.260 arm64 [installed,automatic]

I can probably fix it with a reinstall, but I am very curious to find out what actually happened here?

You forgot to post a link to full logs for the machine not updating.


(The current kodi logs are readable since I waited for the video scan to finish before I tried the update the second time around)

The only additional info that provided that I had forgotten was that when I started testing apt-get dist-upgrade it actually wanted to update, and I let it do so, some packages the first time (both Vero:s did) but none of those were osmc related.

And I probably should move the video files that won’t index properly to an unindexed folder to get less logging on startup.

(It also looks more like this is the older of the two Vero:s given the dates, apparently they got swapped around at some point in time)

So is it just the kernel package itself which is out of date?



From the ones above, and if not one of them, whatever else that is responsible for the version display on the My OSMC screen.

And now that I look at the list again I see something I missed yesterday, the packages on the Vero that did not update actually says [installed, local], not [installed,automatic] so it thinks that none of the repos it knows about contains those packages anymore and that explains why they wont get updated.

But why does it believe that when it sees the repo during apt-get update ??

Looked into this again today, after doing this

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get update

to completely rebuild the package cache, packages were listed as automatic rather than local again and updates started working…


Sorry for missing the follow up on this – ended up opening this on my phone and accidentally closing the tab at the time.

It’s very odd that you experienced corruption like this. If everything updated fine then this would suggest some network issue rather than a local filesystem one.

Glad this is fixed and in the unlikely event this occurs for other users in the future I am sure this will be helpful.



1 Like