[SOLVED] OSMC don't start after update (sade face)

Hi !

I’ve been using this wonderfull media center for a few month now and be pretty pleased with it (exept the no netflix support… damn you netflix !).

When a popup shows up to ask for an update, I’ve said “go on my friend, get new yummy package and continue to amaze me !”… Hum… sorry, I get distracted some times.

After the update completed (I gess, I didn’t see the upgrade progress), the system restarted and since I got a sad face and can’t acces my media center…

I tried serveral thing to fix it up :

  • I’ve booted up directly on OSMC (I got a triple boot with Raspbian by default) → No change
  • I’ve tried to rename the “.kodi” folder to see if one of my addon mess things up (thanks to this topic) → No change
  • I’ve try an upgrade (with the “apt-get dist-upgrade” command, not “apt-get upgrade”) → Nothing to upgrade
  • I’ve checked the partitions space, thanks to this topic → Got room
  • I’ve try the “apt-get install --reinstall” → Didn’t seems to do anything
  • Try an fdisk → Didn’t understand how it works, the only recovery mode I got is the NOOB/PINN one for my multi-boot install.

I run OSMC on a triple boot made with PINN.
The two others boot (Raspbian and RetroPie) are doing fine.

Here’s the comple log : https://paste.osmc.tv/ubotahitoq

Any help will be… helpfull :slight_smile:

Steve

Hi,

Do the logs provided, show with .kodi restored?

Hi have you ran apt-get upgrade in the past for this osmc install? If so this is know to break the system, so you will need to reinstall.

Thanks Tom.

Hi Tom_Doyle !

Yes, the logs are with the .kodi restored.
Here’s one after the renaming (and the “sudo systemctl start mediacenter” command) : https://paste.osmc.tv/yisosagoto

And fortunally, I’ve try the manual upgrade after reading the forum, so only did the “apt-get dist-upgrade”, never the “apt-get upgrade”.
But did an “apt-get update” first…

Hi,

Is this a pi2 or pi3?

Also you could try:

sudo apt-get install rbp2-mediacenter-osmc --reinstall

Thanks Tom.

Thanks !
Oups, forgot : It’s a pi3.
Do I have to backup anything before reinstalling ?

Hi,

Not it will not affect any settings, so no back up required.

Also the noob automated generated config.txt settings, seem to be underclocking the pi. This may actually be the cause of the issue, I would remove at least these lines:

arm_freq=850
core_freq=375

You will need access: to the command line:

https://osmc.tv/wiki/general/accessing-the-command-line/

make a backup:

sudo cp /boot/config.txt /boot/config.bak

make change:

sudo nano /boot/config.txt

Make changes and ctrl-x and yes to save and exit.

and restart the pi.

If you wish to revert:

sudo cp /boot/config.bak /boot/config.txt

Thanks Tom.

The change in the config.txt didn’t do the trick.
I’ve try to delete all the lines under the NOOB settings, didn’t work either.
I’ve reverted theses settings (exept for the underclocking lines I’ve kept deleted)

I’m launching the reinstall of rbp2-mediacenter-osmc.

The reinstallation worked !
But I loose all my config, got a brand new OSMC.
I think I must have messed up the .kodi folder with all the renaming.

But thank Tom_Doyle for the help, it saved me from reinstalling all my other systems (which I spend a tremendous amount off time on).

Glad to hear its sorted.