[SOLVED] OSMC + HiFiBerry DAC+ freezes

Hi All,

searching the forum I found the information below

a) enable it in: My OSMC, Pi Settings b) reboot, c) Select it in Settings, System Audio Output.

Works great to a point. When I go to settings > audio output and change the “audio output device” to ALSA:default(snd_rpi_hifiberry_dacplusAnalog) it just freezes.
Clean install on OSMC stable version. No changes to anything other than installing via App Store Transmission.

Rebooted and tried again, same thing happening. There is a green light on HiFiBerry and both red and green constant on on the RaspberryPi

Will try to troubleshoot but ideas are welcome.

This thread from 8 days ago should answer your question:

Thank you Sir.

Worked like a charm. Tried searching but didn’t find the other post, sorry for the bother :smile:

Hopefully someone will be able to find my post via search!

1 Like

Hi - worked thank you - just one note for anyone else, don’t forget to reboot after disabling LIRC GPIO support, or you’ll be straight back to freezing on attempting to select the HiFiBerry DAC+ as default audio out.