[Solved] OSMC/Kodi Base Sound Volume

Hello, I would like to increase the base sound volume for my set up. I have searched other sound related posts and they do not seem to apply as my recent version seems not to have the exact same settings. OSMC Ver 2018-08-2 and Kodi Ver 17.6.

As far as I can tell, this would normally be changed by changing dB settings in Kodi Audio and Subtitle settings. The thing is, in mine, this setting shows only -dB to 0 dB as the option, so I am not able to set it louder than 0, only less than. Which is of no help at all since I need + dB, ie., greater than zero. It appears earlier versions of Kodi had that option.

Does anyone know anything specifically about this for this version? Please and thank you.

In that same settings area you mention, the top item on the list is Volume and you’re correct, it tops out at 0db being the loudest setting. However, directly below that is the option of Volume Amplification which you can use to boost the volume of any video that seems to be too quiet. Normally you would just do this for the occasional odd video and Kodi will remember this for the next time you play that video.

But I guess you could boost it up where you like and then go to the bottom of that settings page and choose to “Apply to all videos as default”…

As far as I know Kodi has had this for the last several versions including the version you mention…

Cheers,
Robert

Are you using passthrough for your audio, so controlling the volume with and AVR/soundbar, or are you using the Kodi volume control? If using the AVR/soundbar control (passthrough), then it’s a function of that device and can’t be changed on the Kodi end.

Thanks all.

Directly below Volume is something labeled Audio DSP…

Whatever that is, it seems to not be accessible. Whether I have Allow Passthrough on or not.

I do not see any Volume Amplification option, again whether I have Allow Passthrough on or not.

DSP does not work in the current Kodi release, that’s why it’s not changeable.

As I mentioned, if passthrough is on (and that’s probably what you want) then it’s the AVR that is responsible for controlling the volume.

It would probably help if you told us more about your setup. Like what is your OSMC device, how it is connected to your TV/AVR, etc.

If I’m understanding correctly, the function of Passthrough is just that. Sound is not modified and can not be modified between the source and the AVR. It’s just passing through the Pi as is. Is that correct?

However, if I have a video recording from a GoPro saved onto a usb stick that I want to turn up the volume prior to the signal going to the AVR, and I have Passthrough disabled, than there is a way to increase the dB above 0 as in previous versions of Kodi?

Thank you.

Pi 3B+, Digihat, AVR.

Yes, that is correct.

EDIT, this does work, even using passthrough. You just hit your OK button while playing a video to bring up the play menu and select the audio options. You can change the amplification there.

Not sure why my reply to the query was ignored, but the volume amplification setting has always been the correct answer. And it’s located in the place mentioned by the OP, in the Kodi Audio and Subtitle menu, which is the menu available when playing a video and entering via OK, Audio. I have no idea where else he could be looking and seeing a “Volume” setting slider that varies from - xxdb to 0db. So if he’s not seeing the Volume Amplification setting directly below that, there is something wrong… Skin?

However the OP is now querying DSP settings stating that its directly under the Volume setting - which it is not, it’s under the Audio Decoder section in the Main Kodi System Settings.

Someone isn’t being clear and audio formats, passthrough etc aren’t related to the original question.

Cheers,
Robert

Hello, sorry you believe you were ignored. My responses have been intended for all. I don’t post much so maybe there is etiquette I am not aware of.

As you point out, we agree on the location of the Audio and subtitle settings. I think it’s best if I post a couple of pics so all can see what I have been writing about, and then go from there. You can see indeed that there is no audio setting under the db setting and that there is indeed a non functional Audio DSP setting. Let me know if this works, thanks.

https://imgur.com/4y8TGqE

https://imgur.com/R1rTfda

What skin are you using?

I tested with Transparency! and the setting was there. Switched to Estuary, and the DSP setting is gone (I already stated that on Kodi V17 DSP does not work, so that’s not a surprise).

But the volume settings are there, but not adjustable. So this may be a skin issue; I’ll do some more experimenting.

EDIT: I know what’s going on now. I use passthrough, as obviously I’d like my 7.1 tracks not messed with. When watching a 7.1 (I didn’t dig real deep, by guess is any DD/DTS track) the volume settings are grayed out.

Watching something with a MP3, etc type track the volume settings are available.

Has nothing to do with the skin as I first was thinking.

“Enable audio DSP processing” is set to on in your main system settings, bottom of the Audio page.

Turn this off and then in your Kodi Audio and Subtitle setting (Enter while video is playing) that DSP setting will be replaced by the Volume Amplification setting.

Neither the Volume nor Volume amplification will be accessible for any sound format you are passing through.

Cheers,
Robert

Hello. I am using Estuary. Tried OSMC skin just to see but no change.

I’m sorry, I do not see "Enable audio DSP processing’ on the main system settings, bottom of Audio page. I took more pictures so you can see. Thought I would toggle the Passthrough setting on and off, but did not reveal "Enable audio DSP processing’, nor change the sound options in the Audio and subtitle settings.

It also occurred to me that my posting is in the wrong forum by accident, it should really be in the Pi forum. Is there a way to move it?

Thank you.

Main Settings Passthrough Off

Imgur

Main Settings Passthrough On

Imgur

DSP is broken in Kodi v17.

It’s not coming back in Kodi v18. You should disable this option.

You are in Advanced mode in the settings menu. Change to Expert mode and you’ll see the DSP setting to toggle off.

Yes, yes DSP doesn’t work, we know that. The air conditioning in my car doesn’t work either but if I push the Max Air button, it still sets the ducts for Recycling. Similarly here DSP doesn’t work, but if it’s turned on then you won’t see the Volume Amplification setting in the playing video menu.

Cheers,
Robert

Thanks. Switched to Expert Mode. See pic please. Still do not see the DSP setting?

Imgur

Have you see the many times that you’ve been told that DSP does not work with Kodi V17?

This is very odd. I’m also using the same version of OSMC/Kodi as @MarkJ - OSMC Ver 2018-08-2 and Kodi Ver 17.6. and I do have the enable/disable DSP setting. If I toggle it to on then there is also a DSP setting in the popup menu while playing a video. If I toggle it off, the DSP setting is replaced by Volume Amplification in the popup menu.

DSP Toggle

@bmillham - is there some reason you keep stating DSP doesn’t work with Kodi 17? We KNOW that. No one is saying it does. The point is that the setting is there and regardless of the fact it doesn’t work it DOES affect what is visible in the popup video menu. So saying it doesn’t work is true but not relevant as far as I can determine.

MarkJ must somehow have DSP set to on because he’s seeing it in the popup menu and we’re trying to turn it off…

Cheers,
Robert

OK, I dug a little deeper. I’m no expert in configuring Kodi from it’s XML files, but a quick look into my own guisettings.xml file revealed this under the <audiooutput> section:

<dspaddonsenabled default="true">false</dspaddonsenabled>

So maybe find that setting in your guisettings.xml and check that it is false - if not, change it to false, save the file and restart Kodi…

Cheers,
Robert

Thanks, Robert. Whew, what a long journey of many hours on this issue. Tonight I tried to figure out and learn how to work with those xml files but being a noobie, after a couple of hours kind of gave up. So then I thought I’d poke around some more on the gui Audio settings in System. (Your linked pic helped in that I got a better sense of what I was looking for.)

I noted your skin was different and I figured out it was stock OSMC. Since someone else had suggested earlier on the possibility of a skin issue, I tried switching skins to stock OSMC. Nope. Then I thought let’s try resetting all the settings in that section to default. And there it was, the DSP toggle setting!

So in the end, that was it. I had to set all the settings in the Audio section to default. After that it’s as Robert stated, toggle the DSP setting off. Then the Audio setting will show up over in the popup. Then reset Audio settings to my custom configuration. Thankfully, the Audio setting held in the popup and I now can set the audio dB levels at the level I want for all my videos. And in Passthrough mode. :slight_smile:

Thanks again to everyone that contributed to figure this one out. :slight_smile:

EDIT: No, was mistaken. Does not work in Passthrough mode, which makes sense as discussed earlier. Wishful thinking :-p. Darn. But does work fine for non Passthrough in Estuary skin.