[solved] OSMC RC install on RPi 1 Model B - green light blinks 4 times

Hello guys,

I’m new here, although I’ve been using Raspbmc and Crystalbuntu for a while now. I am trying to install the RC version but without success. I downloaded the OSMC_TGT_rbp1_20150331.img.gz image file and wrote it to my SD card. As soon as I insert it, I get 4 blinking lights on the PI. I also tried to write an OpenElec 5 image file to the card and it booted up correctly. I then used the OSMC Windows installer and I again get the same 4 blinking green lights.I set the gpu_mem from 16 to 128 and still not working. Then I decide to rename the self_cd.elf and fixup_cd.elf to self.elf and fixup.elf and it booted! I get the PI rainbow and OSMC installer screen. It starts installing then a few seconds later I get a brief flash message on screen saying “Failed, unable to decompress .tar” or something similar and then the screen changes to installation completed. Upon reboot, I can see a kernel panic: No working init found. After this process, there are a lot of .dtb and .osmc files on the SD card.

Here is the install.log:
Thu Jan 1 00:00:11 1970 Starting OSMC installer
Thu Jan 1 00:00:22 1970 Detecting device we are running on
Thu Jan 1 00:00:22 1970 Mounting boot filesystem
Thu Jan 1 00:00:22 1970 Trying to mount to MNT_BOOT (/mnt/boot
Thu Jan 1 00:00:22 1970 Using device.boot: /dev/mmcblk0p1 and FS: vfat
Thu Jan 1 00:00:22 1970 No preseed file was found
Thu Jan 1 00:00:22 1970 Creating root partition
Thu Jan 1 00:00:22 1970 From a root partition of /dev/mmcblk0p2, I have deduced a base device of /dev/mmcblk0
Thu Jan 1 00:00:22 1970 Determined 0 MB as end of first partition
Thu Jan 1 00:00:22 1970 Calling mkpart for device: /dev/mmcblk0 and fs: ext4 with start 2M and end 100%
Thu Jan 1 00:00:23 1970 Calling fmtpart for partition /dev/mmcblk0p2 and fstype ext4
Thu Jan 1 00:00:25 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
8192 inodes, 8192 blocks
409 blocks (4.99%) reserved for the super user
First data block=0
Maximum filesystem blocks=8388608
1 block group
32768 blocks per group, 32768 fragments per group
8192 inodes per group

Allocating group tables: 0/1 done
Writing inode tables: 0/1 done
Creating journal (1024 blocks): done
Writing superblocks and filesystem accounting information: 0/1 done

Thu Jan 1 00:00:25 1970 Mounting root
Thu Jan 1 00:00:25 1970 Trying to mount to MNT_ROOT (/mnt/root
Thu Jan 1 00:00:25 1970 Using device.root: /dev/mmcblk0p2
Thu Jan 1 00:00:25 1970 Extracting files to root filesystem
Thu Jan 1 00:00:25 1970 Starting extract progress…
Thu Jan 1 00:00:36 1970 Halting Install. Error message was: tar: write error: No space left on device
Thu Jan 1 00:00:37 1970 Extraction of root filesystem completed
Thu Jan 1 00:00:37 1970 Configuring bootloader
Thu Jan 1 00:00:37 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:00:37 1970 Configuring boot cmdline
Thu Jan 1 00:00:37 1970 Configuring /etc/fstab
Thu Jan 1 00:00:37 1970 Successful installation. Dumping log and rebooting system

Anyone knows why the card doesn’t boot out of the box after getting an image write, or why the installer fails to write the tar file? Could it be that the ext4 partition created was not formatted properly?

Appreciate any input or pointers! :smile:

Update: I managed to install OSMC finally. I wrote the image again to the card, renamed self_cd and fixup_cd to self and fixup, changed gpu_mem = 16 to gpu_mem = 128 and then rebooted. It managed to finish the installation and I’m now running OSMC on the Pi :slight_smile: I’m still stumped as to why the Pi didn’t boot with the default configuration.

None of this should be necessary, I just tested this for myself with a fresh install and had zero issues on a 2gb card.

Indeed, these steps shouldn’t be necessary but nonetheless the problem is here. It might be down to a hardware revision of the Pi but it’s weird anyhow. I’ll try later with a smaller card (I’m currently using a Transcend Class 10 16GB microSD) and see how it goes but I never had such problems before up until now with OSMC.

If the light blinks four times, there could be some damage to the boot partition on the sd or maybe the image did not get written correctly.
I had this after setting usb-maxcurrent and reboot.

Heya mcobit,

Thanks for your answer. You were spot on about the SD card problem. I switched to a different 1GB card and another 16GB card and they worked out of the box. It didn’t occur to me at first that the SD might be a problem because I was writing several other images to it and they were booting fine. Thanks again! :wink: