[SOLVED] OSMC, Transmission, fstab

Hello! I am using a router with DD-WRT. I configured SMB and NAS, USB Hard drive is connected to my router and it is works fine. I am installed Transmission client for OSMC. I want download torrents to my NAS. For it I am add my user with password for client to config and one line to /etc/fstab for mounting, but this issue not helped for me and Transmission says error permission… My config:


Transmission config:

"download-dir": "smb://",
"incomplete-dir": "smb://",
"rpc-enabled": true,
"rpc-password": "osmc",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "osmc",

sudo nano /etc/init.d/transmission-daemon:


sudo nano /etc/fstab: /mnt/diskmedia nfs rsize=8192,wsize=8192,timeo=14,intr,rw,x-systemd.automount,auto

Is where my error? Please help me!

Since you mounted the NAS using fstab you should be able to see the files on it by doing:

ls /mnt/diskmedia

If you see them, just change the “download-dir” and “incomplete-dir” to /mnt/diskmedia, it should work.

osmc@osmc:~$ ls /mnt/
osmc@osmc:~$ ls /mnt/diskmedia
ls: unable to open catalog /mnt/diskmedia: No device


Please post the output of:

sudo mount -t nfs /mnt/diskmedia


ls /mnt/diskmedia

Thanks Tom.

Connection timeout…

Reboot the router?

One moment

Rebooted, typed a command - terminal is thinking


osmc@osmc:~$ sudo mount -t nfs /mnt/diskmedia
mount.nfs: Connection timed out - router, - my osmc (for example)


Are you able to ping your router from the pi?

Thanks Tom.

236 packets transmitted, 236 packets received, 0% packet loss


Just re-read your first post where you say you’ve configured SMB, but your fstab shows nfs. Which is it?

Any way try:

sudo mount -t cifs /mnt/diskmedia

and post the output

Thanks Tom.

If you are using nfs it would also be useful to see the output of sudo showmount -e

Yes, I am turned on Samba and NAS in my routrer.

And it is works fine for my devices


Yes but my point is if your using samba, your not going to able to connect to it using nfs, which is what you’ve in your fstab.

Have you tried the command in my last post?

Thanks Tom.

osmc@osmc:~$ sudo showmount -e
clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)

Terminal is thinking about 5 minutes and next

next what?

Terminal didn’t respond since I typed your command. Okay, try again. I am using two partitions of my hard drive in NTFS, ntfs-3g in my router for NTFS support. I turned on Samba file sharing in NAS tab. I am configured for this partitions username and password plus allow it for guests. Now I can connect to NAS from my computer, my phone and OSMC. Now I want download torrents to my NAS via Transmission. Via SSH from OSMS:

mkdir /mnt/diskmedia
sudo mount -t cifs /mnt/diskmedia

But terminal didn’t respond after 2 line.
I find in settings CIFS, maybe I must configure this?



Long shot, but have you removed the nfs entry from fstab? Unlikely but maybe causing conflict with the mount -t command.

Remove the fstab entry, reboot and try the command again.

Thanks Tom.