[Solved] Pi 1, Xbox remote fail

I’ve got a Raspberry Pi (Original, 512mb), and I’ve hooked up my xbox remote with the usb receiver. The remote doesn’t appear to work. My understanding is that xbox remote is supported for Pi1.

I looked at the log file and LIRC says something about no valid configuration file. So, for grins, I renamed the xbox_lircd.config to lircd.config and rebooted to see if that would work (don’t laugh, I’m new to this sort of thing). Alas, it did not.

Any suggestions, or is this a “wait till alpha 5” thing? I’ve checked the other remote posts, but most of them have to do with Pi 2, and a lot of them say that this remote should work out of box with pi 1.

Thanks all!

I’m having the same problem. It seems the OSMC does not support the original XBOX remote yet :frowning:

I have been using a Raspberry Pi 1 with raspbmc and the original XBOX remote works like a charm!!!

Now I bought a Raspberry Pi 2, loaded it with OSMC “RC” and connected everything back up but sadly the remote does not work at all.

I’m using the original remote for nostalgic reasons and because CEC does not work with this TV (I think it’s more the Philips TV’s fault though it is supposed to support it. CEC works ok with the other TV made by Samsung).

Anyway I unplugged and re-plugged the USB remote receiver and these are the dmesg outputs:
[ 121.454711] usb 1-1.5: USB disconnect, device number 5
[ 124.250801] usb 1-1.5: new full-speed USB device number 6 using dwc_otg
[ 124.354364] usb 1-1.5: New USB device found, idVendor=045e, idProduct=0284
[ 124.354396] usb 1-1.5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 124.357609] input: Generic X-Box pad as /devices/platform/bcm2708_usb/usb1/1-1/1-1.5/1-1.5:1.0/input/input2
[ 124.358620] lirc_xbox[6]: inbound endpoint not found

Does this ring a bell to anyone? I’m not so famlilar with lirc… I was always glad it worked out of the box with raspbmc!

It does. Can you please uploada full log?

Well after some googling I just found the solution!!!

The driver “xpad” is blocking lirc.
I created a file /etc/modprobe.d/xpad-blacklist.conf
with just one line:
blacklist xpad
rebooted and now it works perfectly!!
I found the solution here:


Cheers and keep up the good work!

FYI, I installed an early march build and the original xbox remote worked out of the box (but didn’t work occasionally on reboot), but it didn’t seem to work on the RC for me, but I didn’t do any investigation.

This worked for me as well, i was getting very inconsistent results from the dongle post restart. But this fixed it so that it worked every time.

thanks for posting your solution!

Thank you all for your responses to this. I was beginning to think no one noticed me!

It worked flawlessly for me as well. I’ve marked the topic as solved.

Hi, how do you create the file ‘/etc/modprobe.d/xpad-blacklist.conf’ without the correct user permissions?

Getting an error using ftp and file manager.


Okay, Managed to change the root password using Putty to access OSMC and typing ‘sudo passwd root’

I then changed the folder permissions to write access.

Remote working now.


This will be resolved in OSMC shortly

1 Like

Sorry - how did you change folder permission exactly? I’m new to SSH…