Pi 2 - OSMC alpha 4 and xbox remote playback kit


just got a rasp pi 2 toady and first thing i did was try out osmc. I’ve been using raspbmc for a long time on a daily basis and I’d like to say thanks Sam for a very good and stable product.

the pi2 boots very fast with osmc and a cheep microsd card. pretty impressed.

I use the xbox remote playback kit USB reciever + remote for remote control support. Has this been added into OSMC alpha 4 yet? i can see in dmesg that it is detected :
[ 5.126891] input: Chinese-made Xbox Controller as /devices/platform/bcm2708_usb/usb1/1-1/1-1.2/1-1.2:1.0/input/input1

but when i use lsusb (which i had to install) i get an odd response. :
Bus 001 Device 006: ID ffff:ffff

and the device doesn’t work either. I know the receiver and remote work OK as they work well on an pi1 with raspbmc.

i have searched but can’t find an answer, and saw that you did get lirc and remotes included into your blog for Alpha 3.

Is this a pi2 thing, or a osmc thing?

Also, did you notice that the mpeg2 codec is already included in the pi 2? i just bought a license, but then tested afterwards without the code, and it works out of the box! will try the VC1 later.



Support for Xbox Remote is in Pi1 but I have not added this to Pi2 codec yet.

MPEG2 is not included by default in Pi2, you are just decoding it in software without a key

Sam, when you say Pi1 and Pi2 are you meaning Raspbmc and OSMC? I use an xbox1 remote on Raspbmc and tried OSMC alpha 4 on my Pi1 and the remote is not working.

No, since Monday there is a new version of Rasberry Pi available simply called 2.
There are some issues with IR remotes and it´s being worked on.

Haha, yes I noticed there was a new Pi, just confused by Sam’s comment.

Thanks for the update that there are remote issues, I’ll wait patiently.

Thank you,

i feel a fool for forgetting about the software decoding of MPEG2, you disabled it in the pi1, so i had gotten so used to that…

i will look forward to the addition of the remote code, and give the GPIO LIRC stuff a shot in the mean time.

Many thanks,



Is there a chance to add support for this remote in OSMC Alpha 4 for Raspberry pi 2?

Thank you very much for the work :smile:

Already added


1 Like

I just got a Pi2 and am attempting the same thing - I was previously able to use the XBox DVD remote without any problems on my original Pi model B with Raspbmc, but it won’t work for me now with OSMC. I see that the functionality has been added, but I’m not sure what I need to do to get it going - any help would be appreciated!

I’m very excited about OSMC!

Just wondering if you’ve had any luck with this?

I just dug it out a few days ago to check the status, and yes, it appears the remote works now! I just have to wait to upgrade my power supply because I had a rainbow in the corner every few seconds, but I’m really excited that I won’t need to redo our remotes!

Thanks for the reply. intzzz was kind enough to send me a link to this thread below which resolved the issue for me:

Okay, so the problem just got more complicated.

I have an Xbox Remote Dongle attached to a USB to Xbox cable I got on Amazon a few years ago. When I plug it into a powered USB hub with the Raspberry Pi B, the remote works fine. The Pi is powered by the USB hub.

So, I did the same setup for my new Pi2, and the remote works. However, my Pi2 wasn’t getting enough power, so when I plug the Xbox cable into the Pi2, the remote does not work. I really don’t want to have to have a powered USB hub just for the remote, so I’m wondering if it is just possible to plug in the cord, or should I just look to a new remote? Is there a confirmed working IR remote that is fairly cheap and plug and play?

I tried Jebus’s solution, but I wasn’t able to FTP a file into OSMC - how do I get that file in there? Thanks!

You’ll have to SSH into the Pi to create the file (there’s a million tutorials out there), but have you tried updating to RC3? I think I saw in a thread that Sam mentioned this issue would be resolved in that release - so I’m guessing there would be no need for the fix above.

I updated mine to RC3 after I had done the fix, and everything is still working just fine.

Oh thanks! I was about to give up on learning the SSH commands and decided to do a clean install - it works now!

Spoke too soon. Rebooted, and now it doesn’t work…

haha… I just noticed that ‘the thread’ I thought I had read where Sam mentioned that the fix was implemented was this thread - only a few posts above mine.

You can SSH into the Pi using a program called Putty. You’ll need the IP address of your Pi, and the username & password is ‘osmc’.

Once you’re logged into the Pi, enter this:

sudo nano /etc/modprobe.d/xpad-blacklist.conf

That will open a sort of text editor. Type in:

blacklist xpad

And then I think you hit CTRL ‘X’ to exit. It will prompt you to save the file - just hit yes.

Then type ‘exit’ to get out of your SSH session and reboot the Pi. Hopefully that will do the trick.

I really appreciate it… I’ve been struggling all afternoon! Rebooted 3 times and it looks good!

Did you SSH in and blacklist the xpad? Or just do the RC3 update and reboot a bunch of times?

I had to do the blacklist - the remote worked once with RC3, but it stopped once I rebooted, so I implemented the fix.