SOLVED: Play videos from samba share RP2 not working

Everyday I backup new photos and videos from my android mobile with the app syncme via samba onto an external USB hdd connected to my raspberry pi 2 with osmc 3.18.13-1-osmc.

This my smb.conf

cat /etc/samba/smb.conf | grep -v ^# | grep -v '^$'|less 
    config file = /etc/samba/smb-local.conf
    workgroup = WORKGROUP
    follow symlinks = yes
    wide links = no
    unix extensions = no
    lock directory = /var/cache/samba
    load printers = no
    printing = bsd
    printcap name = /dev/null
    disable spoolss = yes
    log level = 1
    map to guest = bad user
    usershare template share = automount template
    read raw = Yes
    write raw = Yes
    strict locking = no
    min receivefile size = 16384
    use sendfile = true
    aio read size = 2048
    aio write size = 2048
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072
    browsable = yes
    read only = no
    valid users = osmc
    path = /home/osmc
    comment = OSMC Home Directory
[automount template]
    browseable = yes
    -valid = no
    valid users = osmc
    path = %P
    hide files = /$RECYCLE.BIN/System Volume Information/desktop.ini/thumbs.db/
include = /etc/samba/smb-shares.conf

sudo tail -f /var/log/
[2015/07/21 13:16:21,  0] ../source3/smbd/server.c:1189(main)
  smbd version 4.1.17-Debian started.
  Copyright Andrew Tridgell and the Samba Team 1992-2013
[2015/07/21 13:16:21.282506,  0] ../lib/util/become_daemon.c:136(daemon_ready)
  STATUS=daemon 'smbd' finished starting up and ready to serve connectionsprocess_usershare_file: stat of /var/lib/samba/usershares/usbhdd1ext4 failed. Permission denied

less /var/lib/samba/usershares/usbhdd1ext4
comment=Auto-mount Volume

osmc@osmc:~$ ls -la /media/usbhdd1ext4/2backup | grep vidbackup
drwxr-xr-x  2 osmc osmc  4096 Jul 16 13:12

Any idea what I am overlooking? My guess is:
This needs to be changed:


Thank you very much in advance!

what happens when you do it?
we need a little explanation

@filledk: Thank you for your fast reply:

VLC tells me translated into English::
p, li { white-space: pre-wrap; }

Your input could not be opened:
VLC, the MRL ‘smb: //osmc@192.168.xx/usbhdd1ext4/2backup/20150716.mp4’ not open. See for details in the error log.
There is no error log of vlc though.
But if vlc is started in bash:
It offers this: (Permission denied)

I think it has to do with Access Control Lists (ACLs) as I mentioned earlier.

You’ll need to provide more context, as you haven’t explained how VLC comes into making your backups, nor where it is running.
As far as I’m concerned, VLC on a Windows based PC is rather tricky about external shares, and I’ve never had any errors logged by it.

This won’t work, because you have left out the password. Try something like this:


Username and password are separated by a colon using the smb:// syntax.

:grinning: Thank you that worked. But why don’t I have to do that with my old raspbmc-shares? Any idea? Thank you in advance!

Almost certainly because of the way the shares are/were defined.
Impossible to expand on that, as it all comes down to the detail (ie where the devil resides)