[SOLVED] Problems connecting to Wi-Fi

Hello all,
I’ve been attempting to install the following file; OSMC_TGT_rbp2_20220527.img.gz on a Raspberry Pi 3 Model B (V1.3) board from 2016.

Not sure if I’m missing the updated image link somewhere, as I can see a WiFi connection issue has been resolved, but any attempt to load this image onto my board works, but WiFi connection does not.

That’s attempting both to provide the WiFi credentials through the OSMC installer when using the image, and when selecting ‘wired’, installing, booting and then providing login details through the actual UI.

Interestingly the attempt to connect fails immediately, no delay whatsoever.

I’d be grateful of any advice! Many thanks in advance.

Preseeding wifi via the installer I believe is not working with that build. The fix that you saw in the testing thread isn’t testable by the public as there is no installer images available at this time. As for connecting after the fact is the network your trying to connect to 5ghz using a channel over 100?

I’m trying to connect to a “standard” home 2.4GHz network. The Pi 3 Model B can’t even see any 5GHz channels as the BCM43438 WiFi/Bluetooth chip operates only in the 2.4GHz spectrum.

Guess I’m waiting on the changes to be rolled into the release images. :slight_smile:

Cheers for your suggestions!

Oops, forgot that came with the 3+. I’m not aware of an issue with 2.4ghz connecting via My OSMC on a fresh install where there was no changes to config.txt. Have you tried loading up an install of Raspberry Pi OS just to sanity check this is not a hardware issue?

Hi there,
I’ve successfully run previous versions of OSMC on the device, having used the images available ‘bundled’ into the installer itself.

My wish to upgrade is driven by the slyguy Disney+ addon not showing video. I was recommended to try upgrading to Bullseye.

Kind regards.

Well bullseye for the newer version of libc, but I know Sam fixed a an OSMC-packaged version of a patched libc in buster.

I can’t speak exactly for disney+, since i haven’t tested it for a few months but I can probably check tonight if I still get it running on 18.9 in buster. And if the Mrs. wont mind terribly, I might be able to test it in v.19 in buster.

I’d suggest to install OSMC_TGT_rbp2_20220314.img.gz and if the wifi is working you can upgrade from that.

@darwindesign Yep, this was a perfect solution.

For anyone else looking;
1: Get any version of OSMC running on your Pi 3 with a data connection.
2: Follow the instructions listed here; [TESTING] Debian 11 Bullseye, moving forward from “…test this update in place…”
3: Success.

Note, following this process also fixed issues I was having with the SlyGuy Disney+ Add-on.

1 Like