[Solved] Problems with recording via VDR and VNSI

i am facing the same issue on a Vero4k+ with OSMC 2023.01-1 (Kernel 4.9.269-21-osmc)

While I can watch TV without any problems can not fast-forwards, rewind or jump within the recordings. Also it seems that the recordings are affected if i copy them to another PC as several Players (VLC, MPlayer) seem to have problems with the *.ts files too.

I receive my signal from a Sat>IP server (Octopus M4) and store the recordings on my NAS. I have a 1Gbit Network connection (cable). I use VDR together with VNSI Server and Client, all are running locally on the Vero 4k+

I prepared a log restarting the Vero around 18:17. I started a record at 18:22 and finished it at 18:25. Afterwards I tried to play the recorded file at: 18:26

My Uploaded Protocolls can be found here:

Thanks in advance for your time

Best Regards


If other applications are having problems with the streams then this may be an issue with the recording itself.

Does it happen with all channels or just some?

I can not tell at the moment, as the problem does not seem to be consistent. In some rare cases (with short recordings) it does not occur. I can do some tests with other channels maybe a SD channel and a HD channel …

I uploaded another protocol where I recorded an SD channel and 2 HD channels. The last recording (2nd HD channel) seems to be aborted as it is much shorter than I recorded ( I recorded more then 2 Minutes while the in replay it says the recording is only some second long)


You’re recording on the device itself?

Is the tuner externally powered?
Are you using the black USB port?

I record to my NAS which is connected via gigabit ethernet and mounted via fstab. On the device itself i am running VDR. VDR gets its signal from an SatIP box (OctopusM4) so there is no TV Card connected directly to my Vero via USB. The black USB Port itself is used for the remote.

Before I switched to VDR I used TVHeadend and it was always able to store my videos on the NAS without problems. I had to leave TVHeadend because I had Errors in the EPG (after switching to SatIP) and frequent crashes of the TVHeadend server which I was not able to resolve. with VDR everything worked nearly out of the box, the only error is the recording error i posted here …

If you can reproduce it on other platforms it might be a good idea to ask the VDR guys. Unfortunately I am only familiar with TVHeadend.

I was able to solve the problem even though I don’t really understand why my solution is working.
As I said before I wrote my recordings to a NAS via SMBv3 which worked fine with TVHeadend for a long time.
After switching to VDR I got the shown problems with ringbuffer overflows. I checked my NAS connection with

dd status=progress if=/dev/zero of=/path/to/largefile.img bs=100M count=1000

and got a performance of around 100Mb/s which to my point of view must me much more than needed.

Anyway, I found a comment in VDR forum mentioning that NFS should improve the performance compared to SMBv3. so I switched the protocol of my NAS connection and immediately solved the problem with my recordings. I am even able to record several channels at once without any problems. So whoever faces the same type of problem: Try switching from SMBv3 to NSF (I use 4.1) it solved the problem for me.

Best regards

This is surprising. I would have expected NFS performance to be in favour of SMB.

For me it is surprising, that the protocol has an influence at all. As I said with SMBv3 i get around 100Mb/s throughput. I do not understand, why this is not enough and NFS is needed. Maybe NFS has less overhead on the Vero processor than SMBv3 but I do not know enough about these topics to give sophisticated answers …