[SOLVED]Raspberry 3b+ doesnt boot up with OSMC

Hi,

i have tried to install OSMC on my Raspberry pi 3 b+, i have tried the installer and NOOBS. Both times the green LED was on 4 times and the pi did not display any image or anything else. I have tried it already on several SD cards, but unfortunately it did not work. I have also tried to add this to the config.txt. Unfortunately also no success. Can you help me?

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
gpu_mem_256=112
gpu_mem_512=144
sdtv_aspect=1

Translated with www.DeepL.com/Translator (free version)

Can you please show a screenshot of the SD card contents when using the OSMC installer?

Have you tried it with another power supply? What all is connected to your RPi? Were these “several SD cards” quality and defiantly not fake?

I installed an older version of osmc the pi boots but i get an install failed: could not mount bootfs.
With the newest the Pi doesnt even boots

Bouth SD Card are SanDisk with 4 and 32GB, I tried with an other Powersupply but got the same result.
To my pi is connected, LAN HDMI, keybourd and power.

Guys i did it, the problem was that i bootet from an sd card adapter

OSMC does not support booting directly from USB. We do support install to a USB drive but only with a SD card inserted to provide the initial boot functions. There are other distro’s available that can boot this way but this may require, depending on the RPi used, to run some terminal commands to enable this type of boot in the hardware.

I can add support for this if there’s enough interest. Would need to think about the best way to support this in our installers and make it configurable.

1 Like

@sam_nazarko
I’d for one very much like to see this feature.
please

It would be great if you could add the ability for OSMC to support booting entirely from USB drive (Stick, reader, HDD or SSD). After all what is the point of wasting a SD-card, if you have a HDD attached anyways?
Eliminating the SD-card, might even save you from one of those annoying SD-card corruption breakdowns.
I already have some other pi’s booting entirely from USB, which btw has been an option for raspbian for quite a while.
Is it a lot of work to enable OSMC to support pure USB boot?

Thanks

1 Like

The installer and initramfs would need changes.
It’s something that can be looked at in the future.