[SOLVED] [RC] connmanctl ethernet tether issues


#6

@h_ramus This is the same msg I used to get, when trying tethering on Alpha 4 - but, i think I had done a dist-upgrade and it was not actually Alpha 4 which I was running.

I tried a couple of things and finally gave up. :frowning:


#7

Thanks @rishibhatia5354. That’s a shame. There should be a way to make things work; well, apart from going back to Alpha4.

Using interfaces file /etc/network doesn’t work. Using connmanctl tethering doesn’t work. What is the next alternative?


#8

Tried going back to Alpha4, even that seems to have the connmanctl command broken.

Is there anyway I can replace the existing connman package with one that works with tethering? Something that can accepting the tethering command as before.

Thanks
H.


#9

After a recent update to OSMC the led from the WiFi it now blinking with activity. The tether command is still not working.

Overall OSMC has been very stable and it’s a great piece of software. The Arctic zephyr skin makes it look even better!


#10

@h_ramus Did you find a way to share internet through ethernet port?


#11

I haven’t so far. I will be waiting for this feature to be implemented at a later stage as currently have limited time to research alternatives.


#12

We are already shipping the latest version of connman.

However, it looks like Ethernet tethering may be disabled by default. Please see the following page, in particular TetheringTechnologies and PersistentTetheringMode:

http://manpages.ubuntu.com/manpages/utopic/man5/connman.conf.5.html

Please try editing /etc/connman.conf and try adding the following two lines:

TetheringTechnologies=wifi,ethernet,bluetooth
PersistentTetheringMode=true

Then reboot. I haven’t tried it myself but in theory that should make it possible to Tether Ethernet and should also keep Tethering active across reboots. (Previously you had to enable it every reboot)

Please heed the warning in the documentation - when you enable Ethernet Tethering you will be creating a DHCP sever on the Ethernet interface which will interfere with normal network operations of other devices on an Ethernet network if you forget to turn it off again before connecting to a normal Ethernet network.

Please let us know whether that works for you and we will consider adding it by default in a future update.


#13

Thanks @DBMandrake! I had the connman.conf file with those entries but the update to RC2 must have reset it.

After including your lines in the /etc/connman.conf file I used the following commands:

Connmanctl enable ethernet
Connmanctl tether ethernet on

The Ethernet port now has internet from WiFi! Fantastic! Thanks for your help!

@TinchoRico-see above


#14

Thanks for the report of success - we will give it some testing of our own and if there are no drawbacks it will probably get enabled in a future update.

Yes at the moment an update to the *-network-osmc package will overwrite any changes to connman.conf, that’s why your change was lost.


#15

These changes have been added and should find their way into the next major update. (Certainly before final release)


#16

Brilliant! Thanks for helping us out @DBMandrake!


#17

I can confirm this works great!

Is there also a way to make a routing between both networks so I can access my SAT-receiver which is connected to the rpi ethernet port from another device which is in the same wifi as the rpi?

Thanks!
Brgrds Scanto


#18

As far as I know the connman tether mode cannot work as a plain router - it provides NAT and a DHCP server, much like a standard internet router.

Keep in mind that even if it did configure itself as a router between two networks that unless it was the default gateway on each network, or the default gateways had a route to it (or individual hosts) you could not route between them anyway.

Although you could set up routing rules manually with iptables the problem is that connman is not designed to auto connect multiple interfaces at once, thus isn’t useful for a router application where you need two networks up all the time.

(The tether mode provides an exception to this rule and allows both networks to auto connect on boot)


#19

Works for me. Thanks @h_ramus @DBMandrake. Great job!


#20

Hello all, i found this topic…

so can i connect directly my RPi2 owncloud/NAS direclty to my OSMC RPi1 with direct/cross ethernet cable? i dont need another NW device between them? my RPi1 is connecting to internet with WiFi dongle. here is my network.


#21

After upgrading to RC3 the Ethernet doesn’t seem to receive internet from Wi-Fi. The ‘connmanctl tether ethernet on’ command works, the /etc/connman.conf file is edited as per the above, the Ethernet gets an IP assigned via DHCP but somehow it doesn’t receive internet from Wi-Fi.

Anyone else experiencing this?


#22

Tethering is now supported via the OSMC interface

Sam


#23

Thanks @sam_nazarko. I’ve played with the interface as well but the issue seems to persist.


#24

You shouldn’t need to edit /etc/connman.conf anymore, the new default settings include tethering:

I’ll have a look tomorrow and see if I can reproduce the problem - only a couple of things have changed that could potentially affect tethering.

One hunch - can you edit /etc/connman.prefs and try changing dnsproxy back to yes, then reboot ?


#25

Thanks @DBMandrake. I’ll try editing connman.prefs tomorrow. I’ll also try reverting the changes made to connman.conf to the original version, I only edited the priority of preferred technologies and tethering technologies.