[SOLVED] [RC] connmanctl ethernet tether issues

Hello there

First of all, great work with getting the release candidate version out. The Alpha 4 was already working great so improvements are always great.

I’m using a Pi 2 with Edimax EW-7811UN USB wifi dongle. I had the ethernet being used an access point for my TV to get internet in the Alpha 4.

I did a fresh install of the RC and most things seem to work fine. However, I have two issues:

  1. the led from the wifi is solid blue. Previously it would blink to
    indicate that it was access data from the router.
  2. potentially related to 1 or not, when using ‘connmanctl tether ethernet on’ command I get an error message and the wifi switches off.

The ‘connmanctl tether ethernet on’ command was working fine in Alpha4 as it was how I managed to get the internet traffic routed to the ethernet port. However, on the RC it doesn’t work at all switching off the wifi in the process. Connmanctl seems to work OK when requesting to enable ethernet so I’m not really sure what seems to be breaking it.

I’ve also done a apt-get update apt-get upgrade but still no joy. Any ideas?



In Alpha 4 we were using the standard Debian connman package - in the RC we have changed to building our own custom version of connman for various reasons. It’s quite possible that our build of connman is missing the tethering functionality, and we would not have noticed this as tethering is not something we are testing/supporting just at the moment. (But I believe Sam has plans to support it at a later date)

The light not flashing with wifi activity is likely to be a difference in the kernel driver for the wifi adaptor - there are quite a lot of kernel and driver changes since Alpha 4. Not sure if much can be done about the behaviour of the light without being able to test that model of adaptor first hand.

I’m interested to see your Edimax adaptor is working - I have an Edimax EW-7811UTC which is a slightly different version than yours, and it is not currently recognised. This is my dmesg output for the adaptor:

[ 3943.235842] usb 1-1.2: new high-speed USB device number 5 using dwc_otg
[ 3943.336851] usb 1-1.2: New USB device found, idVendor=7392, idProduct=a812
[ 3943.336886] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3943.336904] usb 1-1.2: Product: 802.11n WLAN Adapter
[ 3943.336921] usb 1-1.2: Manufacturer: Realtek
[ 3943.336937] usb 1-1.2: SerialNumber: 00e04c000001

Can you post the section of dmesg for your wireless adaptor so we can see the idVendor, idProduct, and see which driver is loading ? Thanks!

Hi @DBMandrake

Thanks for getting back to me.

The wifi worked fine after installation, never had any issues on Alpha4 as well.

Understood re the blinking on activity of the light. I’m not bothered about it and thought it would be related to the tethering issues hence mentioning it.

It’s a shame that the tethering option is not supported at the moment. I’ll have to find another way of routing traffic from wifi to the ethernet. Last time round it took me some time digging it up as I’ve limited knowledge of Linux.

I’ll post my dmesg output later tonight as I currently don’t have the Pi2 with me.



1 Like

Here you go:

[    2.461000] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[    2.562521] usb 1-1.4: New USB device found, idVendor=7392, idProduct=7811
[    2.562552] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.562569] usb 1-1.4: Product: 802.11n WLAN Adapter
[    2.562584] usb 1-1.4: Manufacturer: Realtek
[    2.562600] usb 1-1.4: SerialNumber: 00e04c000001

This is the error message I get when trying to use connmanctl tethering

Error enabling ethernet tethering: Message did not receive a reply (timeout by message bus)

Is there any other way of routing internet traffic from wifi to ethernet?

@h_ramus This is the same msg I used to get, when trying tethering on Alpha 4 - but, i think I had done a dist-upgrade and it was not actually Alpha 4 which I was running.

I tried a couple of things and finally gave up. :frowning:

Thanks @rishibhatia5354. That’s a shame. There should be a way to make things work; well, apart from going back to Alpha4.

Using interfaces file /etc/network doesn’t work. Using connmanctl tethering doesn’t work. What is the next alternative?

Tried going back to Alpha4, even that seems to have the connmanctl command broken.

Is there anyway I can replace the existing connman package with one that works with tethering? Something that can accepting the tethering command as before.


After a recent update to OSMC the led from the WiFi it now blinking with activity. The tether command is still not working.

Overall OSMC has been very stable and it’s a great piece of software. The Arctic zephyr skin makes it look even better!

@h_ramus Did you find a way to share internet through ethernet port?

I haven’t so far. I will be waiting for this feature to be implemented at a later stage as currently have limited time to research alternatives.

We are already shipping the latest version of connman.

However, it looks like Ethernet tethering may be disabled by default. Please see the following page, in particular TetheringTechnologies and PersistentTetheringMode:


Please try editing /etc/connman.conf and try adding the following two lines:


Then reboot. I haven’t tried it myself but in theory that should make it possible to Tether Ethernet and should also keep Tethering active across reboots. (Previously you had to enable it every reboot)

Please heed the warning in the documentation - when you enable Ethernet Tethering you will be creating a DHCP sever on the Ethernet interface which will interfere with normal network operations of other devices on an Ethernet network if you forget to turn it off again before connecting to a normal Ethernet network.

Please let us know whether that works for you and we will consider adding it by default in a future update.

Thanks @DBMandrake! I had the connman.conf file with those entries but the update to RC2 must have reset it.

After including your lines in the /etc/connman.conf file I used the following commands:

Connmanctl enable ethernet
Connmanctl tether ethernet on

The Ethernet port now has internet from WiFi! Fantastic! Thanks for your help!

@TinchoRico-see above

Thanks for the report of success - we will give it some testing of our own and if there are no drawbacks it will probably get enabled in a future update.

Yes at the moment an update to the *-network-osmc package will overwrite any changes to connman.conf, that’s why your change was lost.

1 Like

These changes have been added and should find their way into the next major update. (Certainly before final release)

1 Like

Brilliant! Thanks for helping us out @DBMandrake!

I can confirm this works great!

Is there also a way to make a routing between both networks so I can access my SAT-receiver which is connected to the rpi ethernet port from another device which is in the same wifi as the rpi?

Brgrds Scanto

As far as I know the connman tether mode cannot work as a plain router - it provides NAT and a DHCP server, much like a standard internet router.

Keep in mind that even if it did configure itself as a router between two networks that unless it was the default gateway on each network, or the default gateways had a route to it (or individual hosts) you could not route between them anyway.

Although you could set up routing rules manually with iptables the problem is that connman is not designed to auto connect multiple interfaces at once, thus isn’t useful for a router application where you need two networks up all the time.

(The tether mode provides an exception to this rule and allows both networks to auto connect on boot)

Works for me. Thanks @h_ramus @DBMandrake. Great job!

Hello all, i found this topic…

so can i connect directly my RPi2 owncloud/NAS direclty to my OSMC RPi1 with direct/cross ethernet cable? i dont need another NW device between them? my RPi1 is connecting to internet with WiFi dongle. here is my network.