[Solved] [RC] Mount that worked on Alpha 4 not working

I found a method here on the forum that I used to mount an SMB share on my NAS using fstab. It did the job well on Alpha 4. I’ve tried using the same method on RC, but it doesn’t seem to work for whatever reason.

This is what I’ve added to fstab:

//10.0.0.5/Videos/ /mnt/NAS-media/ cifs username=xxx,password=yyy,uid=1000,gid=1000,iocharset=utf8,sec=ntlmv2,noauto,x-systemd.automount,x-systemd.device-timeout=10 0 0

I followed the method I found here and I believe I added the last part with the timeout to avoid a timer on reboots, after googling the problem. Everything is verbatum as I did with success on Alpha 4. I’ve read that there’s been some changes with the RC, but I have no idea what I need to change.

I’ve ran the command “sudo mount -a” like I did on Alpha4. But the share cannot be found in /mnt/, and qbittorrent doesn’t have access to it.

Try removing x-systemd.devicetimeout - it shouldn’t be needed and may be causing your problems.

Btw mount -a won’t work due to the noauto option. You have to specify the mount specifically to manually mount.

Thanks for the quick reply. I removed the timeout part. I don’t know how to mount the location specifically (I tried sudo mount cifs and got the message “mount: can’t find cifs in /etc/fstab”), so I tried removing noauto and got this:
osmc@osmc:/etc$ sudo mount -a
Couldn’t chdir to /mnt/NAS-media/: No such file or directory

So I’m still stuck. I do have access to the share as I can browse it from within kodi.

Did you create the mount directory under mnt ?

sudo mkdir /mnt/NAS-media/

I most certainly did not! I didn’t remember that from last time at all. Thanks for the help, and thanks for an excellent product!

Same problem, forced to restart by powering

No, this is certainly not the same problem. This issue is >7mos old and was present in a RC version of OSMC. If you are having a mounting issue on the most current version of the software, create a NEW THREAD with a relevant title and include relevant info to the problem including logs.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.