[SOLVED]RPi 2 Crashing and rebooting, all out of the blue

So this started last night.
I had been watching stuff during the day and all worked fine.
When i tried playing a movie last night it rebooted ( showing osmc logo ) and than it rebooted again, and came in to dashboard, and rebooted again.
This kept on happening, sometimes if i used the remote to move one step it worked other times it rebooted.
I unplugged it this morning to se if that helped, which it didnt.
Looking at the log files i see some warnings but i am not skilled enought to determin the root cause.
Thought i would post this here if someone could find the root cause to it, i will keep the mSD card an swap in a new one to continue using the RPi2 but if someone finds a fix i can try and patch it and make sure it works.


Using a iPhone power supply. Changed to a properone and it worked perfectly!

Nov 15 08:51:38 osmc-livingroom kernel: usb 1-1-port2: over-current change

What kind of power supply are you using? And what have you connected to your USB ports?

Hi @fzinken,
Yes you are right, it was the USB.
I have been using a USB wireless adapter to a keyboard, removed that to use with a PC than reconnected it. Noticed this once i used a different mSD in the RPi2.
Thanks, removed it and now it is working again.

Actually removing the USB helped, i can now watch videos on the OSMC however once its finished, it will reboot the device ( reproduced twice now ).

Try another PSU. The WiFi not working properly is just a symptom.

Get a proper powersupply, attaching a (small) USB device causing problems definitely points to power problems. Did you see the colored square in the right top corner?

Sorry for the late reply been abroad.
I tried changing the power supply as welll and this worked perfektly!
Sorry for taking up your time.
Thanks for a awesome software and a great support!

It is good to hear you are up and running.