[Solved] Rpi 3b+ no sound or keeps restarting

Hi,

I’m using OSMC with RPi 3B+ and Pibus on my E39. And I keep having problems with sound.
I’m getting output audio device for Pibus dac when connected on monitor, bet when I insert memory card to RPi in the car I get no sound and device is gone.

With playing randomly with GPIO I can get it back. But if I manage to keep my output device when it’s inserted in the car RPi keeps restarting every few seconds :frowning:

I have this log from it: http://paste.osmc.tv/ruciwiguxi

Maybe someone could tell me where I’m getting problem? Other than that everything is working like it should. Even BMW ibus is working correctly.

Sounds like you may not be providing enough power.

Can it be the case tho? It’s connectes by Pibus manual, so there should be enough power. Plus I have libreelec with kodi on another memory card and it works.

Jul 15 17:15:51 osmc kernel: Under-voltage detected! (0x00050005)

Definitely looks power related.

I get that under-voltage when I’m connecting it to a monitor, I guess monitor doesn’t give enough power from it’s USB. Either way it doesn’t restart even then. But when I connect to a car it’s restarting all over again.

Need to find it’s power supply, to get rid of those under-voltage errors.

Edit: it seems I can’t find it’s power supply, tho tried few mobile phones power supplies and they don’t provide enough power :open_mouth: But I never see that lightning icon when in car.

Edit 2:
how Libreelec works: https://youtu.be/-aa6rn1OiSU
how osmc doesn’t work: https://youtu.be/uo8RD8vpLBI

The monitor won’t provide enough power and using a phone charger is not encouraged.

Solved. Did too much from all the guides I found. There was no infothat newest bmwraspcontrol image have everything done and just need to turn on Pibus board. :slight_smile: