[solved] Sad face loop after unplugging

Hi everyone,

This is happening on a new RPi3 that I set up for the first time yesterday afternoon. It’s my first OSMC experience too, and I must say it’s not going well. I’ve been getting sad face loops all the time yesterday, every time because I unplugged the device after OSMC froze up. Never was I able to recover my guisettings or my database, but I had to start fresh each time by renaming/deleting /home/osmc/.kodi.

The reason for all past crashes before this one was multitasking: I let Kodi scan/import a large source folder from .nfo files while installing and configuring add-ons. Apparently the RPi3 can’t handle that much load at once - it froze, and the only way to get it back was to unplug it.

After unplugging, it would be stuck in the endless sad face loop until I deleted the /.kodi folder. I tried at least salvaging guisettings.xml, but I got the sad face loop every time. So I had to start from scratch each time: set up HTTP access, download skin, add sources…

After doing that about 3-4 times, losing everything, starting from zero, making progress, losing everything, starting from zero again… I realized I had to leave it alone while it was populating the library. So I did, and went to bed last night with it scanning a large folder.

And this morning, it was frozen again. I was able to see the dimmed screen with the UI where I left it - the refresh library process had finished. But it was completely unresponsive to CEC and keyboard. SSH was unable to connect.

So I unplugged it yet again, and now I’ve lost all settings and database yet again… and with that, the better part of yesterday.

I’ll keep my questions short.

  1. Is there any way to reboot OSMC when it’s frozen, short of unplugging?

  2. Is there a way to keep guisettings.xml after unplugging? Kodi wasn’t this sensitive on Windows, where I’ve been running it before the RPi. Just wondering why it won’t start with an old guisettings.

  3. I’d love to know the reason for this endless loop, and why it crashed while just sitting there not doing anything. Here’s kodi.log… not sure if it helps though: http://paste.osmc.io/jujulebilu.coffee

I’d love to get behind this, and I’d appreciate any help. Thank you.

  1. Provide full logs not only kodi.logs
  2. Take out the overclocking first.

Thanks for replying fzinken. I’ll start fresh once agan, enable debugging, and try to replicate the issue, then post back. Overclocking wasn’t on.

Sorry mistake on my side

I decided to do frequent reboots between changes to narrow it down, and it just happened again after installing a few addons:

  • Backup
  • Watchdog
  • Skin: xperience1080 with dependencies
  • a GUI sound theme
  • Yahoo! Weather

After installing the above and rebooting, it’s stuck in the endless sad face loop again… sounds like it must be one of the addons?

The watchdog add-on is frequently implicated with crashes, so that would be my first guess.
But just install the add-ons one at a time and only install the next when you are happy it is still stable to identify the problematic one for sure.

1 Like

Xperience1080 skin doesn’t work with the current version of OSMC. For the time being stick with osmc or Confluence skin

Just search the forum for skin.osmc, I just posted a few hours back how to manually configure it

1 Like

That was indeed the issue. It won’t boot with xperience1080 active. Thanks for that!

For anyone reading this later… here’s the skin thread: Xperience1080 5.x

Thanks again for your help!

Doing that :slight_smile: I found the skin to be the problem that way.

Now that you mention it, I remember seeing a boot message flash on the screen like “watchdog did not shutdown” or so a couple times. Didn’t think much of it at the time - I’ll stay away from it for now though. Thanks for the info!

I have a RPi2 and since Kodi 16 I have also problems with random freezing. But I can restart the mediacenter with SSH. As I read your post about freezes in context with multitasking, I can fully agree with your statement about this problem. Most times I got such freezes was when I update addons and try to navigate in menu at the same time. The freezes occurs at the time before the next menupage is loaded. Probably during the menuanimation. The default log shows nothing. I want to enable the debug log, but I don’t want to see the onscreen message. Any tips?

I also activated overclocking and in my opinion the random freezes occures since overclocking less common.

Adding 1 to advancedsettings should do that. Curious if you can find out anything that way!

On another note, I tried the Aeon Nox skin a few days ago, and it seems to work just fine. No crashes or freezing since. So I’d add that to the list of themes, after Confluence, that should work with the newest OSMC version.

It worked for me but froze after a while. But then OSMC skin froze to.
I use confluence with a mouse on rpi 2 & 3 with osmc no prob.

This is very unforrtunate. None of my favourite skins are working.
Would this be fixed, or we are stuck with the default skin?
It looks like an osmc issue, not kodi

It’s not an OSMC or Kodi issue. It’s that the skin developers have not updated your chosen skins for Kodi 16. If you would like you favourite skin working, then contact that skin developer.

This statement just shows how little research you’ve done into your own issue.

Complain to the skin developers. Xperience1080 5.x

The skins are working fine on Kodi 16.1.
This shows how much research I done into the issue - I added all the missing parts in OSMC and managed to add the skin.
Check this out: Arctic: Zephyr.
Arctic Zephyr (another skin that does not work) is working fine now.
Probably you are right, I should try with OpenELEC. Their support may be a bit better than ‘unistall this addon’, ‘use default skin’, ‘remove pirate (sic) repositories’
Maybe you should have checked before this thread - Dependency xbmc.gui 5.9.0 not satified - #17 by vintxi

Thank you for the badges and trust level.

The Kodi thread I linked for Xperience skin is full of reports of freeze issues across all platforms. It’s not OSMC alone that suffers using that skin.

Get lost troll.

As xperience1080 doesn’t support mouse/touch input try disabling that under Settings -> System -> Input Devices. Then install latest version of OSMC and Xpierence1080 and it should work.