[Solved] SD card or Ethernet module corruption (Updated title)

Hello everybody,

yesterday I updated my Raspberry PI 2 and installed the latest OSMC version, and now the PI is not able to connect to my network again. The other two Pis (one as a server and one with an older version of OSMC) are still connected and I can ping them from my mac.

But the RPi2 is not here… I cannot access it via SSH and check out the logs or the network settings. What can I do. By the way, yesterday it had a connection - for about 1h then it was gone again.

When I open the Network Screen I just see “Enable Adapter (which is on)” with the “Status: No wired connection”. But there is one I tested it.

Can somebody help me pls?

best,
Stefan

Update:

I checked connmanctl state and it says:

* Name = Wired
* Type = ethernet
* Powered = True
* Connected = False
* Tethering = False

BUT the lights on the back of the PI (below the Ethernet cable) are flashing all the time.

and connmanctl services displays nothing.

Update 2:

I just checked “ifconfig” and all I see is lo. there is no eth0 anymore… What just happend after the update? HELP :slight_smile:

Update 3:

ifconfig -a” shows me eth0 again. But I do not know how to go further :wink:

Update 4:

Next I run

  • connmanctl config ethernet_ [mac_address] _cable --ipv4
  • all I got back was: Error ethernet_[mac_address]_cable: Method "SetProperty" with signature "sv" on interface "net.comman.Service" doesn't exist.

===> maybe this helps me? https://communities.intel.com/thread/75725?start=0&tstart=0. I am a little bit afraid to test this without further help of you guys.


other literature (also notes for myself)

might be corruption check dmesg | grep corrupt

2 Likes

im trying too but your not listening it seems so good luck and have fun :slightly_smiling:

Hi Toast,

no sry. It looks like I missed your reply yesterday. Not sure why. SORRY!

I did what you said and this is what I got:

[7.465.088] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

I did this and then fsck from util-linux 2.25.2 was shown. nothing else.

What now? :slightly_smiling:

thx for your help!

So your sd card is corrupted simple as that you need to run FSCK on it

touch /forcefsck

then reboot

then wait

there must be a reason for the corruption are you shutting it down incorrectly ?

this is the reason why your osmc installation has no ethernet not updates… i know thats the users favorite blame game… blame the developer never themselvs

Ok let me test it. I will send you the log/screenshot in a few minutes I guess.

I am shutting it down correctly, or better said: my RPI2 is running almost all the time. I just shut it down when I update it or when I am not at home for some days. But the OSMC itself is not corrupted. Because I can still see the menu and navigate. My thvheadend is also running still.

I will do what you said now and keep you posted.

sry for the dev-blame game.

Okay… now it looks like it is stuck again. All I see now is:

[ 284.951625] watchdog watchdog0: watchdog did not stop!
_

Should I wait or kill it by unplugging the power cable?

its preferable to wait another related question how old is the sd card ? cause that can also be an factor

Okay, then I am gonna wait. It is not that old, I bought it when I got the RPI2 in August 2015. I hope I can avoid setting up OSMC again. Because I installed some plugins, adjusted some things, fixed the missing Sundtek autostart for tvheadend and so on. Do you think we can get there?

might be possible if we get the corruption to be gone make sure you not overclocking like a madman thats also a source of corruption on raspberry pi.

Until now I avoided overclocking my Pi. But one other post suggested to turn on the turbo mode or something to get the eth0 running. It did not work. I will turn if off again.

btw: still stuck here…

well its supposed to run fsck on boot to i guess yank the cable if your really stuck

okay. When you say “on boot” is it correct when I click “Exit” once OSMC is running and then start the console/terminal with ESC? Or is there another way?

I will boot it again, go into the console and run the touch command again.

it should run during the boot process

roger, I started the Pi again… after seeing this (screenshot) I saw OSMC again… but still without ethernet.

try

dmesg | grep corrupt again

wondering if fsck ran

ATTN @fzinken or @sam_nazarko or @DBMandrake penny for your thoughts ?

I did and this is what I got. I also attached a screenshot of the ifconfig command and what connmanctl shows me. Maybe this helps.

Image: http://d.pr/i/ExKQ

I owe you a beer. Just give me your paypal.me address when we are done :wink:

Sounds really tricky, suggest after all this do a dmesg | paste-log so that we can check.

@fzinken hehe remember no ethernet no internet

@natterstefan lets do it manually

sudo -s
umount /boot
fsck.fat -V /dev/mmcblk0p1
fsck.fat -a /dev/mmcblk0p1
mount /boot

hehe yepp a beer sounds nice :stuck_out_tongue:

1 Like