(Solved) - Sharp Aquos 42D64U locks up every few hours

So I bought a second raspberry pi 3 and OSMC remote to use on the kitchen/dining room TV, a Sharp Aquos 42D64U.

Every few hours, or next morning when I try and use it, it’s frozen. No response from the OSMC controller. Swapped with the upstairs OSMC controller. Same issue.

First I thought the pi was defective, but before doing an amazon return, I tried the upstairs OSMC Pi in the kitchen. After a few hours, it also froze.

Tried the kitchen/dining room pi upstairs and that was worked for over a week.

Hmmm…Cannot find any logs. But will try again and update this post.

Without any other info, I am wondering if the CEC signals on the Sharp Aquos is locking up the PI ?

But there again, I would have thought that if you had installed another remote, in this case the OSMC remote, the system would disable/dev null the CEC commands.

Without logs, it’s hard to say what’s going on.

I doubt the OSMC remote control is causing the freezing. When the remote is working, look at the frequency of the blue LED when it flashes. If the remote responds with the same frequency when the device has frozen, it means it is able to communicate with the receiver. If the LED flash is slower, then it means that the device is not paired / the receiver is not powered.

You can disable CEC under Peripherals in Settings -> Input.

Make sure you are running the latest version of OSMC, there have been issues with freezing in the past with Raspberry Pi, but this was many months ago.

Thanks Sam.

I am on the latest osmc.

Turned the CEC off and it hasn’t froze yet.

I will update in a few days.

Thanks again.

As a newbie to kodi/osmc, I have another question ref TV tuners but will start a new thread.

It’s been over a week and no more freezes.

So disabling the CEC worked.


There may be an update for your TV which fixes the problem. But you may find more information about this elsewhere.