[Solved] .srt subtitles not appearing only sometimes

Hey there,

I installed OSMC on my RPi1 B as a test, and surprise! It’s actually faster than OpenElec now! Congratulations guys! Also the skin is very fast, customizable and good looking. Everything was ok until now, when I tried to watch a movie and download .srt subtitles via OSMC. The subtitles get downloaded, are enabled, and appear as selected, but nothing appears on screen. What’s going on? I have verified the subtitle file isn’t empty and it is being saved to a local folder. I also noticed the video calibration settings change from local video to live TV and have to be manually adjusted for each channel. I don’t know if it’s related or not, because when I calibrate the video the subtitle “line” is way under the screen, but I’ve already adjusted it so it’s visible on the screen, but still no subtitles appear.

Any help would be appreciated.

I just tried the following things:

-Redownloading the arial.ttf font and placing it in ~/.kodi/media/Fonts in addition to /usr/share/kodi/addons/skin.osmc/fonts and /usr/share/kodi/media/Fonts
-Changing the subtitle font to teletext.ttf
-Changing subtitle position to “Bottom of video” instead of “Fixed”

This is what happened:
For local files, subtitles finally appeared, even after switching back to Arial, but disappeared after messing with the Video Calibration while the video was playing. Sometimes subtitles appear with the current settings and sometimes with the previous settings (teletext font).
For streamed torrent files, subtitles still didn’t appear, and somehow I got them to show once, but again, disappeared after changing the video calibration or subtitle settings and couldn’t get them to appear again.

It seems that the video calibration (overscan) settings are set on a individual file basis instead of being global settings, and as for why subtitles sometimes appear but sometimes don’t, I have no idea. Maybe there’s some missing file somewhere or a permissions issue.

I also tried switching the skin to Confluence from OSMC. Same results as before.

What could be possibly going on? I never had this issue once with OpenElec; subtitles just worked.


In case anyone cares, the issue was caused by add-on KMediaTorrent, which currently has a bug that disables user subtitles even after you enable them. Also it’s unstable and crashes my Pi after a few minutes but that’s another story.

Thanks anyway.

I know you might already handle this but I still can’t figure it out : (

I don’t use any torrent addon like KMediaTorrent but have the same problem with the subtitles, they just seem to work whenever the want to!

I tried almost everything, adding movies or series to my library and watching them from there, different Subtitles services but still getting the same results, subtitles just appear sometimes, I always check if the subtitles files get downloaded, enabled and selected but they just keep appearing on some titles and on some others not.

I already make some tests on my laptop running the same settings but with the raspberry pi it justs seems not to work.

Here’s my log file in case that any dev can help: http://paste.osmc.io/yojexevosu


After reading a loooooot of threads and looking for an explanation on this rare issue about enabling, downloading and selecting subtitles but never appearing, I read a comment from a guy saying that he was having this same trouble after enabling some advanced settings.

So the way I fix this was by first, removing my advanced settings. But because I was still having buffering issues I just managed it by modifying little by little each option until the problem showed up again.

Just in case anybody has the same problem anytime, here are the best advancedsettings.xml options to fix the caché buffering and also, not to have subtitles issues anymore:

<?xml version="1.0" encoding="utf-8"?>

More useful would be for you to tell us which setting you removed was causing the problem, not the settings you had left after you had removed it. :wink:

Also, please be careful about making blanket recommendations for advancedsettings.xml - specifying a buffer size of 150MB is not necessary unless you have a network problem, and will cause a low memory device like a 256MB Pi to crash. It’s also not recommended on a 512MB Pi as you are wasting a lot of memory that would be better used by the operating system. Combined with additional background service it may also crash due to lack of memory.

Likewise, a readbufferfactor of more than about 8 will not make any real difference in 99% of situations, so setting it as high as 20 is only a placebo.

Im using a RPI2 with 1GB, my last advancedsettings.xml (subtitles issue) were:

<?xml version="1.0" encoding="utf-8"?>

Do you know what you are doing? You know Kodi will need three times the amount of RAM as what you set as buffer size? So that setting definitely will put Kodi into an issue.